Bug 168703 - sshd/X11 does not tunnel iff command placed in background
sshd/X11 does not tunnel iff command placed in background
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
: 168704 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-19 13:01 EDT by jørgen nørgaard
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-23 12:07:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jørgen nørgaard 2005-09-19 13:01:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/412.7 (KHTML, like Gecko) Safari/412.5

Description of problem:
After the most recent up2date, I have a problem with x11 tunnelling over ssh.


If I login using:

ssh -C -Y <key file> -f "$user@$host" "xterm &"

I get the following error:

xterm Xt error: Can't open display: localhost:12.0

If logged in as:
ssh -C -Y <key file> -f "$user@$host" "xterm"

It works.

Backgrounding the login job is to get around limitations in older openssh versions on other systems.



This did not happen before the latest up2date. I run up2date from a terminal started this way and 
afterwards it fails.



Version-Release number of selected component (if applicable):
openssh-4.2p1-fc4.1

How reproducible:
Always

Steps to Reproduce:
1. hard to describe, see above
2.
3.
  

Additional info:
Comment 1 John Mahowald 2005-09-19 13:05:34 EDT
*** Bug 168704 has been marked as a duplicate of this bug. ***
Comment 2 Tomas Mraz 2005-09-19 16:35:12 EDT
I can't reproduce this problem here. The upgrade happened on server or client or
both? Could you please attach logs from both client and server (sshd run with
-ddd ssh with -vvv)?
Comment 3 Tomas Mraz 2005-09-19 17:06:59 EDT
I found a better reproducer:

ssh -Y user@host "(sleep 2; xterm) &"

The code handling setup of X forwarding channels was changed between openssh
4.1p1 and 4.2p1. I'll report this upstream.
Comment 4 Fedora Update System 2006-01-23 12:05:11 EST
From User-Agent: XML-RPC

openssh-4.2p1-fc4.10 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.