This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 168704 - sshd/X11 does not tunnel iff command placed in background
sshd/X11 does not tunnel iff command placed in background
Status: CLOSED DUPLICATE of bug 168703
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-19 13:01 EDT by jørgen nørgaard
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-19 13:03:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jørgen nørgaard 2005-09-19 13:01:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/412.7 (KHTML, like Gecko) Safari/412.5

Description of problem:
After the most recent up2date, I have a problem with x11 tunnelling over ssh.


If I login using:

ssh -C -Y <key file> -f "$user@$host" "xterm &"

I get the following error:

xterm Xt error: Can't open display: localhost:12.0

If logged in as:
ssh -C -Y <key file> -f "$user@$host" "xterm"

It works.

Backgrounding the login job is to get around limitations in older openssh versions on other systems.



This did not happen before the latest up2date. I run up2date from a terminal started this way and 
afterwards it fails.



Version-Release number of selected component (if applicable):
openssh-4.2p1-fc4.1

How reproducible:
Always

Steps to Reproduce:
1. hard to describe, see above
2.
3.
  

Additional info:
Comment 1 jørgen nørgaard 2005-09-19 13:03:08 EDT
Duplicate
Comment 2 John Mahowald 2005-09-19 13:05:27 EDT

*** This bug has been marked as a duplicate of 168703 ***

Note You need to log in before you can comment on or make changes to this bug.