Bug 168726 - Get rid of /usr/bin/eclipse wrapper
Get rid of /usr/bin/eclipse wrapper
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Igor Foox
: FutureFeature
Depends On:
Blocks: 159880 175454
  Show dependency treegraph
 
Reported: 2005-09-19 15:44 EDT by Andrew Overholt
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-04 14:55:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to detect running from a link (6.55 KB, patch)
2005-12-07 13:24 EST, Igor Foox
no flags Details | Diff
Patch 2 (6.26 KB, patch)
2005-12-07 14:03 EST, Igor Foox
no flags Details | Diff
patch 3 (6.34 KB, patch)
2005-12-12 11:29 EST, Igor Foox
no flags Details | Diff
patch4 (6.64 KB, patch)
2005-12-13 15:59 EST, Igor Foox
no flags Details | Diff
patch6 (5.16 KB, patch)
2006-02-03 12:02 EST, Igor Foox
no flags Details | Diff
patch6 (fixed) (5.21 KB, patch)
2006-02-03 12:05 EST, Igor Foox
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Eclipse Project 79592 None None None Never

  None (edit)
Description Andrew Overholt 2005-09-19 15:44:33 EDT
Description of problem:
The wrapper script is no longer necessary.  Let's dump it.

Additional info:
Tom Fitzsimmons is waging an all-out war against wrapper scripts and I've
somehow been roped into it :)
Comment 1 Andrew Overholt 2005-10-09 21:02:13 EDT
I attempted to symlink /usr/bin/eclipse to /usr/share/eclipse/eclipse but
Eclipse has internal checks for locations of necessary jars, etc.  I might have
to patch around that.  I'll investigate more.
Comment 2 Billy Biggs 2005-10-09 22:20:12 EDT
It's actually something I discovered a while back but then never had
a chance to fix.  It's entirely fixable in the launcher code (it is in the
CVS module platform-launcher).

https://bugs.eclipse.org/bugs/show_bug.cgi?id=79592
Comment 3 Igor Foox 2005-12-07 13:24:38 EST
Created attachment 121990 [details]
Patch to detect running from a link

Here's a patch to make the launcher realize that it's being run from a link and
resolve the link using readlink() to find the correct path. It then substitutes
the path for the launcher and also for the the startup.jar.

I'll post this on the upstream bug as well.
Comment 4 Igor Foox 2005-12-07 14:03:55 EST
Created attachment 121991 [details]
Patch 2

Updated patch, improving indentation to conform to the style used in Eclipse
and taking out debug statements that crept in by mistake.
Comment 5 Igor Foox 2005-12-08 11:13:46 EST
Closing, the patch was put in Rawhide and FC4 updates-testing
Comment 6 Igor Foox 2005-12-12 11:29:39 EST
Created attachment 122140 [details]
patch 3

New patch to resolve the problem found in
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=159880 .
Comment 7 Igor Foox 2005-12-12 11:31:19 EST
Not enough coffee. Above should say problem found in
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=175454 .
Comment 8 Igor Foox 2005-12-13 15:59:34 EST
Created attachment 122196 [details]
patch4

I've commented out the memory freeing from the previous patch because it was
segfaulting when the workbench was restarted from within eclipse. Will test
this out for a bit, and if it seems like this is alright, I will remove the
memory tracking altogether, because it just complicates the patch.
Comment 9 Ben Konrath 2006-01-04 15:31:17 EST
This fix is also in updates-testing: eclipse-platform-3.1.1-1jpp_1fc.FC4.11
Comment 10 Igor Foox 2006-02-03 12:02:32 EST
Created attachment 124112 [details]
patch6

I've updated to patch to include the latest fixes but without all the memory
management stuff that was causing errors.
Comment 11 Igor Foox 2006-02-03 12:05:16 EST
Created attachment 124113 [details]
patch6 (fixed)

Fixed the path to the file.

Note You need to log in before you can comment on or make changes to this bug.