Bug 175454 - Unable to access jarfile startup.jar when using alternate VM
Unable to access jarfile startup.jar when using alternate VM
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
4
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Igor Foox
:
Depends On: 168726
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-10 17:19 EST by Robin Green
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 3.1.1-1jpp_1fc.FC4.11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-04 15:48:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Green 2005-12-10 17:19:23 EST
After upgrading eclipse to the updates-testing version, I was unable to run it
with an alternate VM. This problem does not occur if I leave off the -vm command
line argument.

Version-Release number of selected component (if applicable):
eclipse-platform-3.1.1-1jpp_1fc.FC4.8

How reproducible:
Always

Steps to Reproduce:
1. Install JDK 1.5 into /usr/lib/jvm/java-1.5.0
2. eclipse -vm /usr/lib/jvm/java-1.5.0/bin/java
  
Actual results:
Unable to access jarfile startup.jar

and then "JVM terminated. Exit code=1
/usr/lib/jvm/java-1.5.0/bin/java
-jar startup.jar
-os linux
-ws gtk
-arch x86_64
-launcher /usr/bin/eclipse
-name Eclipse
-showsplash 600
-exitdata bb000d
-vm /usr/lib/jvm/java-1.5.0/bin/java
-vmargs
-jar startup.jar"

Expected results:
Normal startup
Comment 1 Andrew Overholt 2005-12-11 14:07:41 EST
I can duplicate this.  Igor?
Comment 2 Igor Foox 2005-12-12 10:47:07 EST
Weird, if I run with --vm it works, if I run with -vm it fails similarly.
Investigating...
Comment 3 Igor Foox 2005-12-12 10:49:08 EST
OK, that's because --vm doesn't do anything, I'll try figure out what's causing
this.
Comment 4 Ben Konrath 2006-01-04 15:48:11 EST
This is fixed in updates-testing with eclipse-platform-3.1.1-1jpp_1fc.FC4.11.

Note You need to log in before you can comment on or make changes to this bug.