Bug 168762 - Space with scim-anthy ascii mode doesn't work in XEmacs
Summary: Space with scim-anthy ascii mode doesn't work in XEmacs
Status: CLOSED DUPLICATE of bug 167783
Alias: None
Product: Fedora
Classification: Fedora
Component: scim-anthy
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-09-20 06:36 UTC by Jens Petersen
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2005-09-20 09:29:11 UTC


Attachments (Terms of Use)

Description Jens Petersen 2005-09-20 06:36:49 UTC
Description of problem:
Using scim-anthy under XIM in XEmacs gives an error when Space is inputted
when scim-anthy is in "ascii" (_A) mode.

How reproducible:
Everytime

Steps to Reproduce:
1. Execute:
# yum install scim-anthy xemacs
$ scim -d
$ export XMODIFIERS=@im=scim
$ xemacs -vanilla
2. Switch scim-anthy to "_A" (ascii) mode with mouse say
3. Input Space in XEmacs window.

Actual results:
3. "  not defined" appears in message window ("minibuffer").

Expected results:
4. Space to appear in buffer.

Additional info:
I haven't seen this in any other XIM apps, so this is likely
a XEmacs XIM bug.  Workaround is to turn off xim for xemacs.
Apparently scim-anthy is the only IM which uses xim for ascii input
iiuc.

Comment 1 Akira TAGOH 2005-09-20 09:29:11 UTC

*** This bug has been marked as a duplicate of 167783 ***


Note You need to log in before you can comment on or make changes to this bug.