Bug 167783 - can't input Space in XEmacs in ascii mode
can't input Space in XEmacs in ascii mode
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xemacs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
: 168762 (view as bug list)
Depends On:
Blocks: SCIM
  Show dependency treegraph
 
Reported: 2005-09-07 22:19 EDT by Jens Petersen
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 21.4.18-2.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-07 04:51:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2005-09-07 22:19:48 EDT
Description of problem:
When scim-anthy is in noconversion (muhenkan) mode it doesn't seem
possible to input Space in XEmacs somehow.

How reproducible:
every time

Steps to Reproduce:
1. Start xemacs.
2. Turn on scim-anthy.
3. Switch ascii input mode.
4. Press Space in xemacs buffer.

Actual results:
"  not defined."

Expected results:
Space in buffer.

Additional info:
Doesn't seem to occur with other IMEs including Japanese ones.
Comment 1 Akira TAGOH 2005-09-13 05:03:42 EDT
I suspect this is a xemacs bug because other Japanese IMEs doesn't support the
noconversion mode which isn't going through preedit. will let me investigate the
details.
Comment 2 Akira TAGOH 2005-09-20 05:29:15 EDT
*** Bug 168762 has been marked as a duplicate of this bug. ***
Comment 3 Akira TAGOH 2006-01-31 02:54:40 EST
It looks like xemacs' XIM implementation has something wrong since this doesn't
happen on emacs. reassigning to xemacs then.
Comment 4 Ville Skyttä 2006-02-06 15:45:49 EST
Unfortunately I have no clue about SCIM/XIM stuff, not even enough to know how
to "turn on scim-anthy", so help and patches are welcome.  XEmacs in devel will
soon be updated to 21.4.19, but IIRC the changelog doesn't have anything that
would sound related.
Comment 5 Jens Petersen 2006-02-07 03:31:48 EST
I can't reproduce this with the current XEmacs packages in FE devel. :)
No problem anymore inputting ascii with scim-anthy or scim-pinyin.
Comment 6 Akira TAGOH 2006-02-07 04:51:13 EST
So it may be good to close this bug once, then reopen it if you have seen it again.

Note You need to log in before you can comment on or make changes to this bug.