Bug 168798 - multipath -ll takes longer time for status updations
multipath -ll takes longer time for status updations
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
:
: 168799 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-20 08:40 EDT by Narasimha Murthy
Modified: 2010-01-11 21:21 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-15 14:38:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Narasimha Murthy 2005-09-20 08:40:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322)

Description of problem:
"multipath -ll" takes longer time for updating the path status, when the utility is executed just after disabling the switch ports to storage. 
This time increases as the retrycount and timeout values are increased for Qlogic HBA driver. However "multipath -l" comes out immediately. 


Version-Release number of selected component (if applicable):
device-mapper-multipath-0.4.5-6.0.RHEL4

How reproducible:
Always

Steps to Reproduce:
1.disable the path to storage, by disabling the port of the concerned switch.
2.issue "multipath -ll" on the host.
3.
  

Actual Results:  Once the command is executed it hangs for a long time and comes out with the new status of the paths.

Additional info:
Comment 1 Suzanne Hillman 2005-09-20 13:02:15 EDT
*** Bug 168799 has been marked as a duplicate of this bug. ***
Comment 2 Lan Tran 2005-10-06 16:18:29 EDT
From my understanding of 'multipath' and Qlogic driver, this may be expected
behavior. Unlike 'multipath -l', 'multipath -ll' will actually try to check the
health of a path by sending some command down to the disk. When you disable a
switch port, the Qlogic driver will have a port or link down timer period that
it waits, suspending I/O during that period, to see if the device will come back
up. Since 'multipath -l' does not send any I/O through the QLogic driver, you
get quick feedback regardless of what you do on the SAN. But multipath -ll and
any other I/O sending command, like 'dd', will seem to 'suspend' during this
period. I think Qlogic uses 60 second for their link down timer period . So by
'hangs for a long time', do you mean you are you seeing it hang for around 60
seconds? If so, I don't think this is a bug. 
Comment 3 Ben Marzinski 2006-09-15 14:38:25 EDT
Since this has been uncommented on in almost a year, I'm closing it. If someone
still thinks there is a bug here, please reopen it.

Note You need to log in before you can comment on or make changes to this bug.