Bug 1688740 - sha512sum(1) man page is badly formatted
Summary: sha512sum(1) man page is badly formatted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: coreutils
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kamil Dudka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1688744
TreeView+ depends on / blocked
 
Reported: 2019-03-14 10:54 UTC by Jonathan Wakely
Modified: 2019-05-22 11:31 UTC (History)
11 users (show)

Fixed In Version: coreutils-8.31-2.fc31 coreutils-8.31-2.fc30 coreutils-8.30-7.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1688744 (view as bug list)
Environment:
Last Closed: 2019-05-05 02:19:41 UTC
Type: Bug


Attachments (Terms of Use)
Patch to patch the patch (1.39 KB, patch)
2019-03-14 10:54 UTC, Jonathan Wakely
no flags Details | Diff

Description Jonathan Wakely 2019-03-14 10:54:46 UTC
Created attachment 1543984 [details]
Patch to patch the patch

The coreutils-6.10-manpages.patch screws up the formatting of the man page (and the note it adds to the --help output is not proper English anyway).

The rendered man page looks like:

       -t, --text
              read in text mode (default)

              Note: There is no difference between binary and text mode option
              on GNU system.  -z, --zero           end each output  line  with
              NUL, not newline,

              and disable file name escaping


Note that the -z option is not a new item, but continues on from the note, and there's a spurious line break after "not newline,". In the troff source the problem is a missing .TP macro and a missing newline, but the man page appears to be generated by help2man so it's not as simple as fixing the troff.

Please either drop the patch completely (it seems unnecessary to me) or fix the formatting and the grammar.

I've attached a patch for the patch, which moves the "Note:" to the end, so it doesn't mess up the formatting of the --text and --zero options. I also fixed the grammar.

Comment 1 Jonathan Wakely 2019-03-14 10:59:31 UTC
I forgot to say that the patch was built in a rawhide mock build and all %check tests passed.

Comment 2 Kamil Dudka 2019-03-14 12:09:18 UTC
Thank you for reporting the bug and preparing the patch!  The original patch was applied to fix bug #406981.  I will send the improved version of the patch upstream so that we do not have to keep it forever.  If they reject the patch, I think it is better to drop it.

Comment 3 Kamil Dudka 2019-03-14 14:03:37 UTC
Patch proposed upstream (I only tweaked it not to exceed the 80 chars line length limit):

https://debbugs.gnu.org/cgi/bugreport.cgi?bug=34856

Comment 4 Kamil Dudka 2019-03-18 09:23:29 UTC
upstream commit:

https://git.savannah.gnu.org/cgit/coreutils.git/commit/?id=ae61b106

Comment 5 Kamil Dudka 2019-03-18 12:54:25 UTC
fixed in rawhide for now:

https://src.fedoraproject.org/cgit/rpms/coreutils.git/commit/?id=2bc851a4

Comment 6 Fedora Update System 2019-05-03 15:03:40 UTC
coreutils-8.31-2.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-9ca41b62f1

Comment 7 Fedora Update System 2019-05-03 15:03:44 UTC
coreutils-8.30-7.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-431fd850b6

Comment 8 Fedora Update System 2019-05-04 01:57:49 UTC
coreutils-8.31-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-9ca41b62f1

Comment 9 Fedora Update System 2019-05-04 02:58:26 UTC
coreutils-8.30-7.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-431fd850b6

Comment 10 Fedora Update System 2019-05-05 02:19:41 UTC
coreutils-8.31-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2019-05-22 11:31:05 UTC
coreutils-8.30-7.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.