Bug 168915 - My Bugs query doesn't URL-encode user name
My Bugs query doesn't URL-encode user name
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.2
All Linux
medium Severity high (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
David Lawrence
:
: 168928 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-21 06:24 EDT by Bradd W. Szonye
Modified: 2013-06-23 22:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-10 18:48:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bradd W. Szonye 2005-09-21 06:24:23 EDT
Description of problem:
The "My Bugs" query URL-encodes the at sign (@) in e-mail addresses, but it
doesn't encode the user name. That's a problem for Sendmail users who use the
"plussed detail" feature to tag e-mail addresses. CGI programs interpret a plus
sign (+) as a space character, so addresses of the form "foo+bar@example.com"
become "foo bar@example.com" unless properly URL-encoded. Because of that, the
"My Bugs" query fails.

How reproducible:
Every time.

Steps to Reproduce:
1. Create a bugzilla account with a plus sign in the user name.
2. Select the "My Bugs" query.
  
Actual results:
The query fails: "The name 'bradd redhat@szonye.com' is not a valid username.
Either you misspelled it, or the person has not registered for a Bugzilla account."

Expected results:
It should have returned results for <bradd+redhat@szonye.com>.

Additional info:
The same problem occurs on links from "My Front Page."
Comment 1 Bradd W. Szonye 2005-09-21 08:08:31 EDT
*** Bug 168928 has been marked as a duplicate of this bug. ***
Comment 2 William Yardley 2006-09-08 03:12:59 EDT
Note - I checked Bugzilla's own bugzilla to see if I should report this, and I
noticed that it's fixed in the version they're running. So maybe this is a fix
that just needs to be backported from upstream.

Doesn't look like there's a lot of activity on this one, seeing as it's been
open for ~ 1 yr.
Comment 3 David Lawrence 2008-09-16 12:53:36 EDT
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.
Comment 4 Bradd W. Szonye 2008-10-10 18:29:00 EDT
Looks like this is fixed in the current release.
Comment 5 David Lawrence 2008-10-10 18:48:24 EDT
Thanks for verifying. Closing.

Dave

Note You need to log in before you can comment on or make changes to this bug.