Bug 168928 - My Bugs query doesn't URL-encode user name
My Bugs query doesn't URL-encode user name
Status: CLOSED DUPLICATE of bug 168915
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
All Linux
medium Severity high (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2005-09-21 08:06 EDT by Bradd W. Szonye
Modified: 2007-04-18 13:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-09-21 08:08:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bradd W. Szonye 2005-09-21 08:06:53 EDT
Description of problem:
The "My Bugs" query URL-encodes the at sign (@) in e-mail addresses, but it
doesn't encode the user name. That's a problem for Sendmail users who use the
"plussed detail" feature to tag e-mail addresses. CGI programs interpret a plus
sign (+) as a space character, so addresses of the form "foo+bar@example.com"
become "foo bar@example.com" unless properly URL-encoded. Because of that, the
"My Bugs" query fails.

How reproducible:
Every time.

Steps to Reproduce:
1. Create a bugzilla account with a plus sign in the user name.
2. Select the "My Bugs" query.
Actual results:
The query fails: "The name 'bradd redhat@szonye.com' is not a valid username.
Either you misspelled it, or the person has not registered for a Bugzilla account."

Expected results:
It should have returned results for <bradd+redhat@szonye.com>.

Additional info:
The same problem occurs on links from "My Front Page."
Comment 1 Bradd W. Szonye 2005-09-21 08:08:23 EDT

*** This bug has been marked as a duplicate of 168915 ***
Comment 2 Bradd W. Szonye 2005-09-21 08:09:02 EDT
Sorry, accidentally re-submitted the bug.

Note You need to log in before you can comment on or make changes to this bug.