Bug 1689940 - [abrt] hexchat: fatal_error(): hexchat killed by SIGABRT
Summary: [abrt] hexchat: fatal_error(): hexchat killed by SIGABRT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hexchat
Version: 30
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Patrick Griffis
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:548cf7be7c213b38cf40ef0e81b...
: 1706334 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-18 13:35 UTC by Wolfgang Ulbrich
Modified: 2019-05-04 11:11 UTC (History)
5 users (show)

Fixed In Version: hexchat-2.14.2-3.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-02 03:33:23 UTC


Attachments (Terms of Use)
File: backtrace (37.31 KB, text/plain)
2019-03-18 13:35 UTC, Wolfgang Ulbrich
no flags Details
File: cgroup (341 bytes, text/plain)
2019-03-18 13:35 UTC, Wolfgang Ulbrich
no flags Details
File: core_backtrace (10.74 KB, text/plain)
2019-03-18 13:35 UTC, Wolfgang Ulbrich
no flags Details
File: cpuinfo (1.75 KB, text/plain)
2019-03-18 13:35 UTC, Wolfgang Ulbrich
no flags Details
File: dso_list (10.12 KB, text/plain)
2019-03-18 13:35 UTC, Wolfgang Ulbrich
no flags Details
File: environ (1.31 KB, text/plain)
2019-03-18 13:35 UTC, Wolfgang Ulbrich
no flags Details
File: limits (1.29 KB, text/plain)
2019-03-18 13:35 UTC, Wolfgang Ulbrich
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1632039 None CLOSED [abrt] hexchat: fatal_error(): hexchat killed by SIGABRT 2019-05-21 20:40:40 UTC

Internal Links: 1632039

Description Wolfgang Ulbrich 2019-03-18 13:35:17 UTC
Description of problem:
Just closed the application with clicking on close button in window-decoration.
It hppens every time i close the application.

Version-Release number of selected component:
hexchat-2.14.2-2.fc30

Additional info:
reporter:       libreport-2.10.0
backtrace_rating: 4
cmdline:        hexchat --existing
crash_function: fatal_error
executable:     /usr/bin/hexchat
journald_cursor: s=1d4f5cc7a71e4384a44220d63b996328;i=87d0f;b=50434900a93042fa807663c5b3d0c4db;m=716f6d030;t=583fb3dbcf607;x=cfb09fce00fb987a
kernel:         5.0.0-300.fc30.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (9 frames)
 #2 fatal_error at /usr/src/debug/python3-3.7.2-7.fc30.x86_64/Python/pylifecycle.c:2179
 #3 Py_FatalError at /usr/src/debug/python3-3.7.2-7.fc30.x86_64/Python/pylifecycle.c:2189
 #4 PyInterpreterState_Delete at /usr/src/debug/python3-3.7.2-7.fc30.x86_64/Python/pystate.c:252
 #5 Py_FinalizeEx at /usr/src/debug/python3-3.7.2-7.fc30.x86_64/Python/pylifecycle.c:1311
 #6 hexchat_plugin_deinit at ../plugins/python/python.c:2819
 #7 plugin_free at ../src/common/plugin.c:141
 #8 plugin_kill_all at ../src/common/plugin.c:353
 #9 hexchat_exit at ../src/common/hexchat.c:994
 #10 mg_tabwindow_de_cb at ../src/fe-gtk/maingui.c:3199

Potential duplicate: bug 1645561

Comment 1 Wolfgang Ulbrich 2019-03-18 13:35:20 UTC
Created attachment 1545230 [details]
File: backtrace

Comment 2 Wolfgang Ulbrich 2019-03-18 13:35:21 UTC
Created attachment 1545231 [details]
File: cgroup

Comment 3 Wolfgang Ulbrich 2019-03-18 13:35:23 UTC
Created attachment 1545232 [details]
File: core_backtrace

Comment 4 Wolfgang Ulbrich 2019-03-18 13:35:24 UTC
Created attachment 1545233 [details]
File: cpuinfo

Comment 5 Wolfgang Ulbrich 2019-03-18 13:35:25 UTC
Created attachment 1545234 [details]
File: dso_list

Comment 6 Wolfgang Ulbrich 2019-03-18 13:35:26 UTC
Created attachment 1545235 [details]
File: environ

Comment 7 Wolfgang Ulbrich 2019-03-18 13:35:28 UTC
Created attachment 1545236 [details]
File: limits

Comment 8 Wolfgang Ulbrich 2019-03-18 13:36:13 UTC
Similar problem has been detected:

Just closed the application with clicking on close button in window-decoration.
It hppens every time i close the application.

reporter:       libreport-2.10.0
backtrace_rating: 4
cmdline:        hexchat --existing
crash_function: fatal_error
executable:     /usr/bin/hexchat
journald_cursor: s=1d4f5cc7a71e4384a44220d63b996328;i=87d0f;b=50434900a93042fa807663c5b3d0c4db;m=716f6d030;t=583fb3dbcf607;x=cfb09fce00fb987a
kernel:         5.0.0-300.fc30.x86_64
package:        hexchat-2.14.2-2.fc30
reason:         hexchat killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 9 Fedora Update System 2019-04-30 23:43:57 UTC
hexchat-2.14.2-3.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-544b84d67e

Comment 10 Fedora Update System 2019-05-01 01:44:32 UTC
hexchat-2.14.2-3.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-544b84d67e

Comment 11 Wolfgang Ulbrich 2019-05-01 10:10:48 UTC
Thanks, this fixes the problem with the annoying daily abrt alarm.

Comment 12 Fedora Update System 2019-05-02 03:33:23 UTC
hexchat-2.14.2-3.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 enricobe 2019-05-04 11:11:03 UTC
*** Bug 1706334 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.