This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 168999 - mid air collision mechanism is broken
mid air collision mechanism is broken
Status: CLOSED WONTFIX
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.18
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-21 18:49 EDT by Mike A. Harris
Modified: 2007-04-18 13:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-27 05:58:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike A. Harris 2005-09-21 18:49:12 EDT
Description of problem:
When a mid air collisions occurs when submitting an update to a bug, you
are given 2 choices:

1) Throw away my changes and revisit bug
2) Submit my changes anyway, possibly overwriting the other person's changes.

Option #2 is 100% broken.  If you hit "submit anyway" what happens, is
bugzilla brings you to a blank white page with no content, and throws away
your changes even though you told it to submit your changes anyway.

This causes all of your work to be lost which is especially frustrating if
you just typed in 30 minutes worth of text or something.

How reproducible:
This problem is 100% reproduceable 100% of the time.  Every single mid
air collision I encounter does this always.

Steps to Reproduce:
1. Bring up a bugzilla bug
2. Bring the same bug up in another browser tab/window/etc.
3. Add a comment to the bug in window #1 and submit it.
4. In the second bug tab/window, do not reload the bug.  Just add another
   comment to the bug, and submit it.  This will simulate a 2 user mid
   air collision.
5. On the mid-air-collision screen, select "submit my changes anyway".
  
Actual results:
Bugzilla spins for a few seconds then presents you with a completely white
page with no content on it.  Now, open a new window and bring the original
bug back up.  Observe that your changes were thrown away even though you
chose "submit my changes anyway".


Expected results:

It is expected that bugzilla commit the changes you have made when you choose
"submit my changes anyway" so that your work is not lost.


Additional info:

The way it works right now, there is always a race condition window where
a mid air collision can destroy your work.  The only way to prevent this
right now, is to cut and paste all of your changes into a text file before
submitting to bugzilla, just in case a mid-air-collision happens.

This is very frustrating when it happens with a large amount of text data.
Comment 1 David Lawrence 2006-04-08 13:52:52 EDT
Red Hat's current Bugzilla version is 2.18. I am moving all older open bugs to
this version. Any bugs against the older versions will need to be verified that
they are still bugs. This will help me also to sort them better.
Comment 2 Mike A. Harris 2006-10-27 05:58:53 EDT
This bug is still present.  I had originally filed it because I encountered
the problem on a daily basis pretty much all of the time, and I lost valuable
data that I had input, causing loss of work and thus loss of efficiency.  A
very frustrating experience shared by many.

However, my usage of bugzilla nowadays is signficantly less than before now,
and I'm much less likely to encounter the problem on any sort of frequent
basis, so I am no longer interested in tracking the issue, although it would
be nice if someone would fix it at some point, as the issue wastes a lot of
man-hour resources both inside Red Hat (thus reducing shareholder value), and
outside of Red Hat, causing customer/user/developer frustrations.

Closing..

Note You need to log in before you can comment on or make changes to this bug.