Bug 1690232 - Fluentd doesn't output it's logs to STDOUT when LOGGING_FILE_PATH=console
Summary: Fluentd doesn't output it's logs to STDOUT when LOGGING_FILE_PATH=console
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: Josef Karasek
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks: 1693035 1693036 1693043
TreeView+ depends on / blocked
 
Reported: 2019-03-19 05:45 UTC by Qiaoling Tang
Modified: 2019-06-04 10:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1693035 1693036 1693043 (view as bug list)
Environment:
Last Closed: 2019-06-04 10:46:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:46:15 UTC
Github openshift origin-aggregated-logging pull 1566 None None None 2019-03-21 14:36:19 UTC

Description Qiaoling Tang 2019-03-19 05:45:30 UTC
Description of problem:

Per https://bugzilla.redhat.com/show_bug.cgi?id=1651884#c4, when  LOGGING_FILE_PATH=console, should use "oc logs $fluentd-pod" to view fluentd pod logs, but in fact, it doesn't show pod logs. 

Set LOGGING_FILE_PATH=console makes fluentd store it's own logs to "/opt/app-root/src/console"


Version-Release number of selected component (if applicable):
4.0.0-0.nightly-2019-03-18-200009
quay.io/openshift/origin-logging-fluentd:latest

How reproducible:
Always

Steps to Reproduce:
1.Deploy logging
2.Set LOGGING_FILE_PATH=console in ds/fluentd, then check fluentd pod logs:
$ oc set env ds/fluentd LOGGING_FILE_PATH=console

$ oc exec fluentd-dvmk4 env |grep LOGGING_FILE
LOGGING_FILE_PATH=console
LOGGING_FILE_AGE=10
LOGGING_FILE_SIZE=1024000

$ oc logs fluentd-dvmk4
=============================
Fluentd logs have been redirected to: console
If you want to print out the logs, use command:
oc exec <pod_name> -- logs
=============================
3.

Actual results:


Expected results:
Should be able to use "oc logs $fluentd-pod" to view pod log when LOGGING_FILE_PATH=console


Additional info:

Comment 1 Qiaoling Tang 2019-03-27 01:16:37 UTC
Verified in quay.io/openshift/origin-logging-fluentd@sha256:0799e9558732b84d58d1afc58fb1aced00737af435198202115460b90aa655d0

Comment 3 errata-xmlrpc 2019-06-04 10:46:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.