Bug 1693043 - Fluentd doesn't output it's logs to STDOUT when LOGGING_FILE_PATH=console
Summary: Fluentd doesn't output it's logs to STDOUT when LOGGING_FILE_PATH=console
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.10.z
Assignee: Noriko Hosoi
QA Contact: Anping Li
URL:
Whiteboard:
: 1729459 (view as bug list)
Depends On: 1690232
Blocks: 1693035 1693036
TreeView+ depends on / blocked
 
Reported: 2019-03-27 02:31 UTC by Qiaoling Tang
Modified: 2019-07-12 14:00 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1690232
Environment:
Last Closed: 2019-06-11 09:30:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin-aggregated-logging pull 1578 None None None 2019-03-29 23:31:45 UTC
Red Hat Product Errata RHBA-2019:0786 None None None 2019-06-11 09:30:59 UTC

Description Qiaoling Tang 2019-03-27 02:31:19 UTC
+++ This bug was initially created as a clone of Bug #1690232 +++

Description of problem:

Per https://bugzilla.redhat.com/show_bug.cgi?id=1651884#c4, when  LOGGING_FILE_PATH=console, should use "oc logs $fluentd-pod" to view fluentd pod logs, but in fact, it doesn't show pod logs. 

Set LOGGING_FILE_PATH=console makes fluentd store it's own logs to "/opt/app-root/src/console"


Version-Release number of selected component (if applicable):
logging-fluentd-v3.10.129-1

How reproducible:
Always

Steps to Reproduce:
1.Deploy logging
2.Set LOGGING_FILE_PATH=console in ds/fluentd, then check fluentd pod logs:
$ oc set env ds/fluentd LOGGING_FILE_PATH=console

$ oc exec fluentd-dvmk4 env |grep LOGGING_FILE
LOGGING_FILE_PATH=console
LOGGING_FILE_AGE=10
LOGGING_FILE_SIZE=1024000

$ oc logs fluentd-dvmk4
=============================
Fluentd logs have been redirected to: console
If you want to print out the logs, use command:
oc exec <pod_name> -- logs
=============================
3.

Actual results:


Expected results:
Should be able to use "oc logs $fluentd-pod" to view pod log when LOGGING_FILE_PATH=console


Additional info:

Comment 1 Anping Li 2019-04-09 09:37:45 UTC
The PR wasn't merged to latest image loggging-fluentd:v3.10.129. Waiting another image

Comment 6 Anping Li 2019-04-22 09:07:32 UTC
The bug was fixed in v3.10.139

Comment 8 errata-xmlrpc 2019-06-11 09:30:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0786

Comment 9 Rich Megginson 2019-07-12 14:00:00 UTC
*** Bug 1729459 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.