Bug 1690363 - Firefox on Wayland: context menus and windows (other than the browser window) are invisible on a low-DPI monitor when a high-DPI monitor is plugged in
Summary: Firefox on Wayland: context menus and windows (other than the browser window)...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 30
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jan Horak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ffwayland
TreeView+ depends on / blocked
 
Reported: 2019-03-19 10:36 UTC by Quint Guvernator
Modified: 2019-11-19 10:24 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-19 10:24:35 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Quint Guvernator 2019-03-19 10:36:16 UTC
Description of problem:

When starting Firefox 66 on Fedora 29 with the "Firefox on Wayland" .desktop entry, if a higher-DPI monitor is plugged in, Firefox won't show the following windows consistently:

* context menus
* add bookmark
* menus created by extensions
* "overflow" toolbar menu

These can be interacted with using the keyboard, but those interactions aren't visible. For example, bookmarking a page would normally pop the small, docked "add a bookmark" window. The bookmark icon in the address bar looks like it's selected, as if the window were created, and you can hit ESC on the keyboard to cancel adding a bookmark, but no window is displayed. The right-click context menu works the same way: it exists, and you can interact with it using the keyboard, but it isn't visible. Ditto with my my password manager.

Version-Release number of selected component (if applicable):

* Firefox 66 installed from  https://koji.fedoraproject.org/koji/taskinfo?taskID=33603998
* Fedora 29

Steps to Reproduce:

1. install Firefox 66
2. plug in a monitor with a lower DPI than the one you already have
3. launch with "Firefox on Wayland" using "Type to search..." or "Show Applications" launcher
4. if necessary, move Firefox to the lower DPI monitor
5. right-click to trigger a context menu, or click the bookmark button in the address bar, or open the overflow menu

Actual results:

These elements aren't visible, but can be interacted with.

Expected results:

These elements ought to be visible.

Additional info:

Split from https://bugzilla.redhat.com/show_bug.cgi?id=1679517, where the mitigation was to start Firefox using the "Firefox on Wayland" .desktop entry.

Comment 1 Chris Hubick 2019-03-24 04:16:23 UTC
This sounds like what I'm experiencing on my single-monitor box (40" 4K TV).

Comment 2 Martin Stransky 2019-03-25 15:05:49 UTC
Can you please try latest builds? (https://bodhi.fedoraproject.org/updates/FEDORA-2019-0767b70f4a) It contains fixes for hidpi systems. Thanks.

Comment 3 Chris Hubick 2019-03-28 06:10:02 UTC
At first glance, everything is working again now, for me. Thanks!

Comment 4 Quint Guvernator 2019-03-28 11:27:02 UTC
Looks great! Thanks Martin.

Comment 5 Quint Guvernator 2019-11-19 09:47:10 UTC
Hi folks, this bug remains. I don't remember how long ago it returned, but it's still here on Fedora 30 with FF 70.0.1 (64-bit) on Wayland and GNOME.

Comment 6 Martin Stransky 2019-11-19 10:00:08 UTC
Jan, can you look at it please?
Thanks.

Comment 7 Quint Guvernator 2019-11-19 10:24:35 UTC
After some investigation, it turns out the new instance of the bug persists regardless of monitor DPI. Between that and the fact that it's only a partial regression of this older bug, I thought it ought to be its own bug: https://bugzilla.redhat.com/show_bug.cgi?id=1773911. I'll close this one as WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.