Bug 1690958 - gns3-server: not able to install
Summary: gns3-server: not able to install
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gns3-server
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Othman Madjoudj
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1710239 (view as bug list)
Depends On: 1668654
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-20 14:46 UTC by Carl George
Modified: 2019-09-15 21:58 UTC (History)
3 users (show)

Fixed In Version: gns3-server-2.1.16-3.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-09 01:32:38 UTC


Attachments (Terms of Use)

Description Carl George 2019-03-20 14:46:10 UTC
Description of problem:
In Fedora 30, gns3-server is not installable.

Version-Release number of selected component (if applicable):
gns3-server-2.1.11-2.fc30

How reproducible:
always

Steps to Reproduce:
1. dnf install gns3-server

Actual results:
Last metadata expiration check: 2:21:16 ago on Wed 20 Mar 2019 12:20:00 PM UTC.
Error: 
 Problem: conflicting requests
  - nothing provides python3.7dist(prompt-toolkit) = 1.0.15 needed by gns3-server-2.1.11-2.fc30.x86_64
(try to add '--skip-broken' to skip uninstallable packages)

Expected results:
successful installation

Additional info:
This is related to bug 1475812.  Ipython 7 and ptpython 2 needed prompt_toolkit 2, so I proceeded with updating prompt_toolkit in rawhide (which has now made it's way into branched f30).  At the time upstream wasn't compatible, so I opened https://github.com/GNS3/gns3-server/issues/1424.  That have reported that they have removed the prompt_toolkit dependency in 2.2, but may add it back (with prompt_toolkit 2) in version 2.3.

Comment 1 Fedora Update System 2019-04-28 00:02:35 UTC
gns3-server-2.1.16-3.fc30 gns3-gui-2.1.16-2.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-d2fc8ca380

Comment 2 Othman Madjoudj 2019-04-28 00:06:18 UTC
Thank you for reporting the issue, it should be fixed in the update FEDORA-2019-d2fc8ca380, basically I patch out prompt_toolkit as temporary workaround while waiting for 2.2 (still alpha) and 2.3

Comment 3 Othman Madjoudj 2019-04-28 00:09:33 UTC
*** Bug 1696631 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2019-04-29 17:40:25 UTC
gns3-gui-2.1.16-2.fc30, gns3-server-2.1.16-3.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-d2fc8ca380

Comment 5 Fedora Update System 2019-05-09 01:32:38 UTC
gns3-gui-2.1.16-2.fc30, gns3-server-2.1.16-3.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 6 Othman Madjoudj 2019-09-15 21:58:53 UTC
*** Bug 1710239 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.