Bug 1696631 - Dependency Problem
Summary: Dependency Problem
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gns3-server
Version: 30
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Othman Madjoudj
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1707515 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-05 10:21 UTC by Héctor Louzao
Modified: 2019-05-09 01:32 UTC (History)
2 users (show)

Fixed In Version: gns3-server-2.1.16-3.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-28 00:09:33 UTC


Attachments (Terms of Use)
log while installing with pip3 (6.30 KB, text/plain)
2019-04-08 12:37 UTC, Héctor Louzao
no flags Details

Description Héctor Louzao 2019-04-05 10:21:07 UTC
Description of problem:

when I install gns3-server doens't install because dependency problem

Version-Release number of selected component (if applicable):

gns3-server-2.1.11-2.fc30

How reproducible:

Always

Steps to Reproduce:

1. Installi it 
2. Error
3.

Actual results:

[hhlp@localhost ~]$ LANG=C sudo dnf install gns3-server
keybase                                          17 kB/s | 3.3 kB     00:00    
Error: 
 Problem: conflicting requests
  - nothing provides python3.7dist(prompt-toolkit) = 1.0.15 needed by gns3-server-2.1.11-2.fc30.x86_64
(try to add '--skip-broken' to skip uninstallable packages)

Expected results:

sucessfull instalation 

Additional info:

N/A

Comment 1 Héctor Louzao 2019-04-08 12:37:23 UTC
Created attachment 1553597 [details]
log while installing with pip3

It doesn't work when I install it with PIP3 too...

see Log

Regards.,

Comment 2 Fedora Update System 2019-04-28 00:02:36 UTC
gns3-server-2.1.16-3.fc30 gns3-gui-2.1.16-2.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-d2fc8ca380

Comment 3 Othman Madjoudj 2019-04-28 00:09:33 UTC
It should be fixed with the update above, please test the update and provide karma,

Marking as duplicate of 1690958 since it contains ref to upstream bug

*** This bug has been marked as a duplicate of bug 1690958 ***

Comment 4 Fedora Update System 2019-04-29 17:40:26 UTC
gns3-gui-2.1.16-2.fc30, gns3-server-2.1.16-3.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-d2fc8ca380

Comment 5 Othman Madjoudj 2019-05-08 23:22:02 UTC
*** Bug 1707515 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2019-05-09 01:32:39 UTC
gns3-gui-2.1.16-2.fc30, gns3-server-2.1.16-3.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.