Bug 169110 - Bengali Khanda Ta character for Unicode 4.10
Bengali Khanda Ta character for Unicode 4.10
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fonts-indic (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Darshan Santani
:
Depends On:
Blocks: Indic
  Show dependency treegraph
 
Reported: 2005-09-23 00:32 EDT by Leon Ho
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: fonts-bengali-2.0.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-01 07:04:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixed Lohit Bengali Font (135.57 KB, application/x-font-ttf)
2006-04-01 12:05 EST, Baishampayan Ghose
no flags Details
Test Case (50 bytes, text/plain)
2006-04-01 12:08 EST, Baishampayan Ghose
no flags Details

  None (edit)
Description Leon Ho 2005-09-23 00:32:35 EDT
Need to add U+09CE
Quote from http://www.unicode.org/versions/Unicode4.1.0/#SignifAdditions
"In Bengali a dead consonant TA shows up as U+09CE BENGALI LETTER KHANDA TA in
all contexts except where it is immediately followed by one of the consonants
TA, THA, NA, BA, MA, YA, or RA. Khanda-Ta cannot bear a vowel matra or combine
with a following consonant to form a conjunct aksara. It can form a conjunct
aksara only with a preceding dead consonant RA, with the latter showing up as a
REPH placed on the Khanda Ta.

Previous versions of the Unicode Standard recommended that Khanda-Ta be encoded
as TA + VIRAMA + ZWJ. Instead, the Khanda-Ta should be used explicitly in new
text, but users are cautioned that instances of the old encoding may exist."
Comment 1 Baishampayan Ghose 2006-04-01 12:05:15 EST
Created attachment 127179 [details]
Fixed Lohit Bengali Font

I have fixed the font and have made a few additional changes to it for
improvement. The changes are as follows --

* Added the Bengali Khanda Ta character to U+09CE
* Added four new conjuncts to the font to make it functionally complete
  - ka + Ta + ra
  - ma + tha
  - la + ta
  - la + dha
* Added the darhi (danda & double danda) glyphs to U+0964 & U+0965 so that the
bengali font doesn't need to depend on any devanagari font for those glyphs.
* Changed the em-height of the font from 769 to 1024 for compliance with the
conventions and also since the font was found to be too small by default.
Comment 2 Baishampayan Ghose 2006-04-01 12:08:39 EST
Created attachment 127180 [details]
Test Case

Attached is a file with the new conjuncts and the khanda-ta
Comment 3 Tim Mayberry 2006-04-12 22:49:57 EDT
I tested your modifications to the font briefly by visiting
http://www.bbc.co.uk/bengali/ and all the glyphs that were missing using the old
font are now displayed.

I'm sorry I can't give you more feedback as to the additions that you've made to
the font, as I am not familiar with bengali script.

It looks like some of the other indic fonts are also missing the glyphs for
U+0964 and U+0965 which is probably the reason for bug 183144.
Comment 4 Leon Ho 2006-04-13 08:24:12 EDT
Baishampayan: Thanks for your contribution to the Lohit fonts project. Because I
saw there are some new glyphs which you have made, we may need you to follow our
project guideline at http://fedoraproject.org/wiki/Lohit

After signed the CLA, I will also also include your copyright (stated with your
contributions) into a separate file (i.e. COPYRIGHT or Changelog) other than the
copyright notice area in the font itself, coz it won't scale when we have great
number of contributions. :)

Also the font seems to have many fixes, instead of fixing this particular bug.
Next step I probably need to do is to have a repo with bfd (which is in textual
format), so we can accept patches for individual fixes. We may need your help
again to contribute your fix one by one.

Feel free to let me know if you have any ideas for the Lohit project on how to
streamline the process of this font development. Thanks again for your effort.
Comment 5 Baishampayan Ghose 2006-04-13 08:58:12 EDT
(In reply to comment #4)
Leon,
> Baishampayan: Thanks for your contribution to the Lohit fonts project. Because I
> saw there are some new glyphs which you have made, we may need you to follow our
> project guideline at http://fedoraproject.org/wiki/Lohit
> 
> After signed the CLA, I will also also include your copyright (stated with your
> contributions) into a separate file (i.e. COPYRIGHT or Changelog) other than the
> copyright notice area in the font itself, coz it won't scale when we have great
> number of contributions. :)
I have signed the CLA. And I agree that putting in the Copyright notice in the
font itself doesn't scale :)
 
> Also the font seems to have many fixes, instead of fixing this particular bug.
> Next step I probably need to do is to have a repo with bfd (which is in textual
> format), so we can accept patches for individual fixes. We may need your help
> again to contribute your fix one by one.
Yes, it has quite a few fixes in it. I am willing to send in patches one by one.
Do tell me how to proceed. 

> Feel free to let me know if you have any ideas for the Lohit project on how to
> streamline the process of this font development. Thanks again for your effort.
There are a few other issues with this Bengali font as well as the other Lohit
fonts. I would like to discuss those with you some time later ...
Cheers,
BG
Comment 6 Darshan Santani 2006-07-21 10:57:15 EDT
FIXED. 

Additional Info:

BZ # 179821  [https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=179821] 
Comment 7 Darshan Santani 2006-07-31 09:55:54 EDT
FIXED in RAWHIDE. 
[fonts-indic-2.0-2]
Comment 8 Satyabrata Maitra 2006-09-01 07:04:09 EDT
This problem is fixed now. Closing the bug.

Component Version tested :

fonts-bengali-2.0.1-1

Rawhide i386.

Note You need to log in before you can comment on or make changes to this bug.