Bug 179821 - addition of newly recognised unicode codepoint U09CE for Bengali
addition of newly recognised unicode codepoint U09CE for Bengali
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fonts-indic (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Darshan Santani
: FutureFeature, i18n
Depends On:
Blocks: Indic
  Show dependency treegraph
 
Reported: 2006-02-03 02:29 EST by Runa Bhattacharjee
Modified: 2013-03-03 21:20 EST (History)
4 users (show)

See Also:
Fixed In Version: fonts-bengali-2.0.1-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-31 03:23:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of U09CE written in gedit on RHEL4 (31.87 KB, image/png)
2006-02-22 03:47 EST, Runa Bhattacharjee
no flags Details
screenshot of current bn Lohit version in FC5 (56.69 KB, image/png)
2006-03-29 07:30 EST, Runa Bhattacharjee
no flags Details
screenshot of modification made by community user (50.24 KB, image/png)
2006-03-29 07:31 EST, Runa Bhattacharjee
no flags Details
Patch attached (167.78 KB, patch)
2006-07-21 10:47 EDT, Darshan Santani
no flags Details | Diff

  None (edit)
Description Runa Bhattacharjee 2006-02-03 02:29:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050921 Red Hat/1.0.7-1.4.1 Firefox/1.0.7

Description of problem:
The newly recognised unicode codepoint 09CE for bengali-phonetic layout 'Probhat' has to be added on the shift+8 i.e. * key.

Reference: [https://bugs.freedesktop.org/show_bug.cgi?id=1012]

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Newly recognised bengali unicode codepoint U09CE missing on the keyboard.
2. Has to be added on the shift+8 i.e. * keypoint
3.
  

Additional info:
Comment 1 Jens Petersen 2006-02-16 20:46:15 EST
Thanks for the report.  So it is not needed for the inscript map?

Would you be able to make a patch of "/usr/share/m17n/bn-probhat.mim"
to handle that?
Comment 2 Jens Petersen 2006-02-17 07:07:46 EST
Is the glyph already included in our bengali font btw?
Comment 3 Lawrence Lim 2006-02-19 17:52:44 EST
No, U+09CE is not within our font package, fonts-bengali-1.10-2.1. 

Hmm...also noticed that U+09CE is not in the Unicode 4.0, could be part of
revision thereafter. 
Comment 4 Runa Bhattacharjee 2006-02-19 22:41:17 EST
The glyph is present in the ttfonts-bn-1.10-1.EL version that i am using in
RHEL4. But the character  can be written with >1 keypresses.

Jens, what kind of a patch can be prepared for this? If i know correctly a XKB
patch  has been submitted for this at
https://bugs.freedesktop.org/show_bug.cgi?id=1012. Will this help?

hth
Runa
Comment 5 Jens Petersen 2006-02-22 03:15:32 EST
I'm confused now: as far as i can see U+09CE is already bound to "*"
in bn-probhat.mim:

  ("*" ?ৎ)

and I'm able to input it with scim-m17n.  I also agree with Lawrence
that it does not display with the font in fc5 anyway, just appears as
a missing glyph box.

How do you write the character with >1 keystrokes?
Comment 6 Jens Petersen 2006-02-22 03:29:20 EST
Doesn't display with RHEL 4 ttfonts-bn-1.10-1.EL either for me.
Comment 7 Runa Bhattacharjee 2006-02-22 03:47:41 EST
Created attachment 125012 [details]
screenshot of U09CE written in gedit on RHEL4
Comment 8 Jens Petersen 2006-02-22 04:23:32 EST
The glyph in question needs to be moved to U+09CE.
[Re-assigned to fonts-bengali.]
Comment 9 Runa Bhattacharjee 2006-02-22 04:26:24 EST
The keysequence for U09CE on bn-probhat on RHEL4 is:

f/+-

+ is ZWJ
- is ZWNJ
Comment 10 Runa Bhattacharjee 2006-03-09 03:34:08 EST
The keysequence for U09CE on bn-probhat on RHEL4 is:

f/-


- is ZWNJ

The ZWJ is not to be used.
Apologies for the mess.
thanks
Runa
Comment 11 Jens Petersen 2006-03-09 06:29:32 EST
(bn-probhat.mim should get fixed in 1.3.3-2.)
Comment 12 Runa Bhattacharjee 2006-03-14 07:44:12 EST
Hi,
I tested the fonts on FC5 test3 : fonts-bengali-1.10-2.1. The U09CE character is
not showing when input using RAW UNICODE Value in scim.

I am getting queries from the community about Unicode 4.1 compliant
Lohit-Bengali. As of now I have pointed them to the fedora download site but
since its the same version they are going to come back complaining.

any updates on this issue and any answers that i can give back to the community.

 There are quite a few fonts that are currently available at
http://www.ekushey.org/projects/otf_bangla_fonts/ [ the same group who were
distributing proprietory MS fonts]. They have also named one of their fonts as
ekushey Lohit.

thanks a lot
runa
Comment 14 Runa Bhattacharjee 2006-03-23 02:09:08 EST
hi,
sorry to be a bother, but are there any updates on this issue as i m getting
persistent queries from the community.
thanks
runa
Comment 15 Leon Ho 2006-03-23 07:26:11 EST
So the work of this is to move the glyph from the gsub table (which combined by
keystroke f/- where - is ZWNJ) to codepoint U+09CE using a font editor.
Comment 16 Runa Bhattacharjee 2006-03-28 06:33:56 EST
Member from bn_IN community has reported 4 missing conjuncts [rarely used] in lohit:
1. ma+tha (09AE+09A5)
2. la+ta  (09B2+09A4)
3. la+dha (09B2+09A7)
4. ka+Ta+ra (0995+099F+09B0)

He says that he has fixed #4 and has put up the screenshot at
http://ubuntu-in.org/lohit-test.pdf

He also has fixed up the 09CE issue on the .ttf.

I have requested him to put up the corrected version at a public place which he
would be doing soon. He wants to know if Red Hat would be accepting the changes
made by him.

thanks
Runa
Comment 17 Runa Bhattacharjee 2006-03-29 00:43:34 EST
Modified fonts have been put up at: http://ubuntu-in.org/ghoseb/lohit-new.tar.gz
Comment 18 Runa Bhattacharjee 2006-03-29 07:30:09 EST
Created attachment 126973 [details]
screenshot of current bn Lohit version in FC5
Comment 19 Runa Bhattacharjee 2006-03-29 07:31:54 EST
Created attachment 126974 [details]
screenshot of modification made by community user
Comment 20 Runa Bhattacharjee 2006-03-29 07:40:36 EST
I tested the fonts. The issues listed have been fixed. But the base fonts that
he has used is wrong.[lohit-new.png] Looks like a SHREE version that had been
rejected earlier on. Have pointed him to the lastest version in the Fedora
Development tree [lohit-old.png]



Additionally, I am not really sure about the legalities involved with the name
"Lohit" for the modified fonts. is it ok?
thanks
Runa
Comment 21 Darshan Santani 2006-07-21 10:47:01 EDT
Created attachment 132816 [details]
Patch attached

Patch has been attached to resolve the issue. (Though this patach will also
resolve BZ# 197216) Thanks
Comment 22 Satyabrata Maitra 2006-07-27 08:54:09 EDT
installed the latest fonts from rawhide. The U09CE character is
not available with this update. Require test RPm to test the Patch updated.

Version-Release number of selected component

fonts-bengali-2.0-1
Comment 23 Darshan Santani 2006-07-31 09:55:22 EDT
FIXED in RAWHIDE. 
fonts-indic-2.0-2]
Comment 24 Satyabrata Maitra 2006-08-31 03:23:19 EDT
This problem has been fixed now. unicode char U09CE is appearing properly now by
typing in RAWCODE and Pressing <shift>+8 (*) selecting Probhat keyboard Layout
from the SCIM-Bengali.

Tested Component version : fonts-bengali-2.0.1-1. (FC6 Test2)

So, I am closing this bug for now.

Note You need to log in before you can comment on or make changes to this bug.