Bug 1691999 - file conflict messages from upgrade of rubygem-irb
Summary: file conflict messages from upgrade of rubygem-irb
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: ruby
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Vít Ondruch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1692129 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-23 05:22 UTC by George R. Goffe
Modified: 2019-03-26 09:55 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-25 09:19:53 UTC


Attachments (Terms of Use)
gzip'd flat file containing dnf upgrade log (855 bytes, application/gzip)
2019-03-23 05:22 UTC, George R. Goffe
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1691039 None ON_QA F29 to F31 KDE upgrades fail on ruby-irb / rubygem-irb conflict 2019-03-25 09:15:21 UTC

Description George R. Goffe 2019-03-23 05:22:17 UTC
Created attachment 1547190 [details]
gzip'd flat file containing dnf upgrade log

Description of problem:dnf upgrade of this system produced messages about file ownership(?). see included log

Additional problem: rubygem-irb does not appear to be in the list of components at the top of this form

Version-Release number of selected component (if applicable):
rubygem-irb-1.0.0-117.fc31.noarch

How reproducible:
always

Steps to Reproduce:
1.dnf -y upgrade
2.
3.

Actual results:
error messages... see log

Expected results:


Additional info:

Comment 1 Satish Balay 2019-03-24 01:22:41 UTC
I get similar issue on F30

[root@sb ~]# rpm -q rubygem-irb.noarch
rubygem-irb-1.0.0-117.fc30.noarch
[root@sb ~]# yum update
Last metadata expiration check: 0:02:32 ago on Sat 23 Mar 2019 08:17:57 PM CDT.
Dependencies resolved.
========================================================================================================================================================================
 Package                                Architecture                      Version                                      Repository                                  Size
========================================================================================================================================================================
Upgrading:
 rubygem-irb                            noarch                            1.0.0-118.fc30                               updates-testing                             66 k

Transaction Summary
========================================================================================================================================================================
Upgrade  1 Package

Total size: 66 k
Is this ok [y/N]: y
Downloading Packages:
[SKIPPED] rubygem-irb-1.0.0-118.fc30.noarch.rpm: Already downloaded                                                                                                    
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/share/ruby/irb from install of rubygem-irb-1.0.0-118.fc30.noarch conflicts with file from package rubygem-irb-1.0.0-117.fc30.noarch
  file /usr/share/ruby/irb/cmd/chws.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/cmd/fork.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/cmd/help.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/cmd/load.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/cmd/nop.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/cmd/pushws.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/cmd/subirb.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/completion.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/context.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/ext/change-ws.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/ext/history.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/ext/loader.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/ext/multi-irb.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/ext/save-history.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/ext/tracer.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/ext/use-loader.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/ext/workspaces.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/extend-command.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/frame.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/help.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/init.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/input-method.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/inspector.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/lc/error.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/lc/help-message conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/lc/ja/encoding_aliases.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/lc/ja/error.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/lc/ja/help-message conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/locale.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/magic-file.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/notifier.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/output-method.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/ruby-lex.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/ruby-token.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/slex.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/src_encoding.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/version.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/workspace.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/ws-for-case-2.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch
  file /usr/share/ruby/irb/xmp.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc30.noarch and rubygem-irb-1.0.0-118.fc30.noarch

Error Summary
-------------

[root@sb ~]#

Comment 2 Satish Balay 2019-03-24 01:26:55 UTC
Ok - I could work-around i with:

yum remove rubygem-irb

yum install rubygem-irb rubygem-rdoc

Comment 3 George R. Goffe 2019-03-24 11:51:19 UTC
Satish,

Thanks for your input.

My purpose was to report this to the package's maintainer so other people wouldn't have to workaround the problem and, possibly, with other packages as well.

George...

Comment 4 Vít Ondruch 2019-03-25 09:13:09 UTC
*** Bug 1692129 has been marked as a duplicate of this bug. ***

Comment 5 Vít Ondruch 2019-03-25 09:19:53 UTC
Sorry for the troubles. Of course, this is a result of trying to fix bug 1691039. I hope the issue is currently just when updating 117 -> 118 and I am afraid the best way to move forward is the suggestion in comment 2, i.e. remove and install rubygem-irb. Another possibility is probably to downgrade to 116 and update to 118.


Note You need to log in before you can comment on or make changes to this bug.