Bug 1692129 - file conflict when updating to rubygem-irb-1.0.0-118.fc31 in Rawhide
Summary: file conflict when updating to rubygem-irb-1.0.0-118.fc31 in Rawhide
Keywords:
Status: CLOSED DUPLICATE of bug 1691999
Alias: None
Product: Fedora
Classification: Fedora
Component: ruby
Version: rawhide
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Vít Ondruch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-24 14:34 UTC by Andre Robatino
Modified: 2019-03-25 09:13 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-25 09:13:09 UTC


Attachments (Terms of Use)

Description Andre Robatino 2019-03-24 14:34:56 UTC
Description of problem:

[root@localhost ~]# dnf update rubygem-irb
Last metadata expiration check: 0:04:43 ago on Sun 24 Mar 2019 10:20:28 AM EDT.
Dependencies resolved.
====================================================================================================
 Package                 Architecture       Version                       Repository           Size
====================================================================================================
Upgrading:
 rubygem-irb             noarch             1.0.0-118.fc31                rawhide              66 k

Transaction Summary
====================================================================================================
Upgrade  1 Package

Total size: 66 k
Is this ok [y/N]: y
Downloading Packages:
[SKIPPED] rubygem-irb-1.0.0-118.fc31.noarch.rpm: Already downloaded                                
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/share/ruby/irb from install of rubygem-irb-1.0.0-118.fc31.noarch conflicts with file from package rubygem-irb-1.0.0-117.fc31.noarch
  file /usr/share/ruby/irb/cmd/chws.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/cmd/fork.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/cmd/help.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/cmd/load.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/cmd/nop.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/cmd/pushws.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/cmd/subirb.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/completion.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/context.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/ext/change-ws.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/ext/history.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/ext/loader.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/ext/multi-irb.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/ext/save-history.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/ext/tracer.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/ext/use-loader.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/ext/workspaces.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/extend-command.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/frame.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/help.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/init.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/input-method.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/inspector.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/lc/error.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/lc/help-message conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/lc/ja/encoding_aliases.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/lc/ja/error.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/lc/ja/help-message conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/locale.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/magic-file.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/notifier.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/output-method.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/ruby-lex.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/ruby-token.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/slex.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/src_encoding.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/version.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/workspace.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/ws-for-case-2.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch
  file /usr/share/ruby/irb/xmp.rb conflicts between attempted installs of rubygem-irb-1.0.0-118.fc31.noarch and rubygem-irb-1.0.0-118.fc31.noarch

Error Summary
-------------

[root@localhost ~]#

Version-Release number of selected component (if applicable):
rubygem-irb-1.0.0-118.fc31.noarch

How reproducible:
always

Comment 1 Andre Robatino 2019-03-24 14:41:38 UTC
Same problem in F30 with rubygem-irb-1.0.0-118.fc30.noarch.

Comment 2 Andre Robatino 2019-03-24 15:41:18 UTC
Looks like a dupe of https://bugzilla.redhat.com/show_bug.cgi?id=1691999 (but that was filed against rubygem-fog which I think is the wrong component). As mentioned in https://bugzilla.redhat.com/show_bug.cgi?id=1691999#c2 , this can be worked around by removing rubygem-irb and then reinstalling the removed packages.

Comment 3 Vít Ondruch 2019-03-25 09:13:09 UTC

*** This bug has been marked as a duplicate of bug 1691999 ***


Note You need to log in before you can comment on or make changes to this bug.