Bug 169218 - Jonas post-script fails (rebuild-gcj-db not found)
Jonas post-script fails (rebuild-gcj-db not found)
Status: CLOSED DUPLICATE of bug 170433
Product: Fedora
Classification: Fedora
Component: java-1.4.2-gcj-compat (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Fitzsimmons
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2005-09-25 02:14 EDT by Ivan Gyurdiev
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-10 16:29:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2005-09-25 02:14:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050827 Fedora/1.1-0.2.8.deerpark.alpha2 Firefox/1.0+

Description of problem:
/var/tmp/rpm-tmp.27634: line 24: /usr/bin/rebuild-gcj-db: No such file or directory
error: %post(jonas-4.3.3-1jpp_11fc.i386) scriptlet failed, exit status 127

/var/tmp/rpm-tmp.94650: line 1: /usr/bin/rebuild-gcj-db: No such file or directory
error: %post(jonas-examples-4.3.3-1jpp_11fc.i386) scriptlet failed, exit status 127



Version-Release number of selected component (if applicable):
jonas-4.3.3-1jpp_11fc

How reproducible:
Didn't try

Steps to Reproduce:


Additional info:
Comment 2 Florian La Roche 2005-10-25 06:56:35 EDT
Is this with a fres install of the FC-development tree?
Comment 3 Florian La Roche 2005-10-25 06:58:14 EDT
fres -> fresh
Comment 5 Paul Nasrat 2005-10-25 16:42:54 EDT
Did you have any additional java packages installed - particularly those using
alternatives from JPackage.

If you have a different alternative selected /usr/bin/rebuild-gcj-db is not
there which is *not* an RPM bug.
Comment 6 Ivan Gyurdiev 2005-10-25 16:57:29 EDT
Yes, I use jpackage, with the Sun Javac.
I see rebuild-gcj-db appear when gcj is chosen.

However, I don't see how that's not a bug - sure looks like one to me. I see
scripts failing, duplicate packages being left in the rpm database, and
unnecessary confusion that the end user should not be subjected to. 
Comment 7 Jeremy Katz 2005-10-26 12:10:10 EDT
If the scripts fail on removal, the package is left installed by design.
Comment 8 Paul Nasrat 2005-10-26 13:30:35 EDT
Gary - if people have switched to a non gcj java package the slave symlink will
not be present.  Perhaps the %post packages should use the full path to the
file, or the script should not be controlled by alternatives.
Comment 9 Thomas Fitzsimmons 2005-10-27 00:37:48 EDT
No, rebuild-gcj-db should never have been made an alternative.  We need to
create a separate java-gcj-compat-scripts package that java-1.4.2-gcj-compat
depends on and that depends on jpackage-utils.  In that package we should put
all these gcj-specific scripts.  If no one beats me to it, I'll do this next
week; there are many duplicates filed for this issue.
Comment 10 Thomas Fitzsimmons 2005-11-10 16:29:31 EST

*** This bug has been marked as a duplicate of 170433 ***

Note You need to log in before you can comment on or make changes to this bug.