Bug 170433 - Package tries to provide "rebuild-gcj-db" via alternatives
Package tries to provide "rebuild-gcj-db" via alternatives
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: java-1.4.2-gcj-compat (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Fitzsimmons
:
: 169218 171843 (view as bug list)
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2005-10-11 13:59 EDT by Bill Crawford
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.4.2.0-40jpp_52rh
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-14 13:50:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Crawford 2005-10-11 13:59:56 EDT
Description of problem:
A number of packages (e.g. eclipse and its subpackages) rely on the presence of
/usr/bin/rebuild-gcj-db.
Unfortunately if I have selected the Sun jre as my default via alternatives,
this fails, and lots of packages end up reporting errors during
post{install,upgrade,remove} scriptlets/triggers.

Version-Release number of selected component (if applicable):
1.4.2.0-40jpp_51rh

How reproducible:
Install this package. Select Sun jre/jvm via alternatives. Upgrade or install
any other package which depends on /usr/bin/rebuild-gcj-db being available.

Actual results:
Error messages during yum update.

Expected results:
Nonesuch.

Additional info:
This simply shouldn't be accessed via alternatives, at least not for those
packages that need it available by default. Perhaps there could be a symlink
provided somewhere either by the java-blah-gcj-compat package itself, or via a
different mechanism (or, make that command not be a slave, but an alternative in
its own right; that seems like overkill, though, just providing it directly
should be enough).

This also means it is very difficult to have e.g. different versions of the gcj
jvm installed, among other things. Plus, what if other jvm packages need some
kind of database like this? Perhaps an /etc/jvm/rebuild-db.d/ needs to be added?
Comment 1 Sammy 2005-10-11 20:43:17 EDT
I can confirm this as well. 
Comment 2 Bryce McKinlay 2005-10-12 21:44:11 EDT
rebuild-gcj-db doesn't seem to belong in the java-gcj-compat package. Is there
any reason not to move it into the libgcj package?
Comment 3 Thomas Fitzsimmons 2005-10-12 22:36:55 EDT
We could do that. However, I'm also going to create a java-gcj-compat-scripts
package that sits above jpackage-utils and below java-gcj-compat.  It would
contain these miscellaneous gcj-specific scripts, such as rebuild-gcj-db,
rebuild-security-providers and aot-compile-rpm.  I think rebuild-gcj-db would
fit in fine there, and having it there rather than in libgcj would give us more
flexibility to experiment with it.  I think once we get the functionality that
we want we should build it directly into gcj-dbtool itself.
Comment 4 Thomas Fitzsimmons 2005-11-10 16:27:50 EST
*** Bug 171843 has been marked as a duplicate of this bug. ***
Comment 5 Thomas Fitzsimmons 2005-11-10 16:29:41 EST
*** Bug 169218 has been marked as a duplicate of this bug. ***
Comment 6 Thomas Fitzsimmons 2005-11-14 13:50:53 EST
Fixed in Rawhide, java-1.4.2-gcj-compat-1.4.2.0-40jpp_52rh.

Note You need to log in before you can comment on or make changes to this bug.