Bug 16922 - :gserver: access method stop cvs on assertion in client.c
Summary: :gserver: access method stop cvs on assertion in client.c
Status: CLOSED DUPLICATE of bug 76557
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cvs   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-25 07:39 UTC by Pawel Salek
Modified: 2007-03-27 03:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:47:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pawel Salek 2000-08-25 07:39:14 UTC
I have been trying to setup a test network CVS server with Kerberos GSS
authentication. I set up tickets, inetd.conf as described in cvs
documentation. I have tested also that :pserver: method was functional.

Trying to access CVS respository with :gserver: method crashes the client
on assertion
in src/client.c:1410. It seems (as far as I could understand, I am not
Kerberos expert) the server requests buffer size of order 24kB, while cvs
has fixed size buffer of max size 1024 bytes. 

I file it as cvs component bug (because it was cvs which dumped core) but I
wonder if it isn't really krb5 bug, because it is the server response which
seems wrong.
I use the krb5 from Redhat Errata. 
PS. cvs-1.10.7-7 doesn't build from src.rpm as non root.

Comment 1 Pawel Salek 2000-08-28 16:54:42 UTC
I tested GSS authentication on IMAP, and it works.
I get reports in /var/log/messages that inetd dies on signal 1.  It is the
executed child,  not the main inetd, as far as I can tell.



Comment 2 Nalin Dahyabhai 2000-10-02 06:05:47 UTC
The not-rebuilding-as-non-root problems should be fixed in the 7 release of
1.10.8.  The gserver assertion will need further debugging.

Comment 3 Martin Stransky 2005-03-17 09:48:20 UTC

*** This bug has been marked as a duplicate of 76557 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:47:45 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.