Bug 76557 - cvs asserts in server.c (line 6038) when used with method gserver and the Kerberos server is on Win2000 domain controller with ActiveDirectory
cvs asserts in server.c (line 6038) when used with method gserver and the Ker...
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: cvs (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
Ben Levenson
:
: 16922 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-23 09:07 EDT by Pavel Tsekov
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-14 04:37:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Tsekov 2002-10-23 09:07:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
gserver_authenticate_connection () in server.c uses a char buffer with a fixed
size of 1024 bytes to get the response from a KDC. It seems that this buffer is
not enough when the KDC is a Windows2000 Server with ActiveDirectory, maybe even
with other Kerberos implementations

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run a GSSAPI authentication capable CVS server
2.Try some cvs command for example: cvs -d :gserver:host:cvsroot log somefile.c
	

Actual Results:  Assertion is printed on the client side.

Expected Results:  The cvs command should complete successfully.

Additional info:

CVS used is the one that comes with RedHat Linux 8.0 - cvs-1.11.2-5
Comment 1 Martin Stransky 2005-03-14 04:37:32 EST
https://ccvs.cvshome.org/issues/show_bug.cgi?id=239
Comment 2 Martin Stransky 2005-03-17 04:48:22 EST
*** Bug 16922 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.