Bug 169323 - OpenOffice.org is not accessible on x86_64
OpenOffice.org is not accessible on x86_64
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: libgail-gnome (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
bzcl34nup
: Reopened
Depends On:
Blocks: 169147 175205 175206
  Show dependency treegraph
 
Reported: 2005-09-26 20:30 EDT by Dave Malcolm
Modified: 2013-01-09 22:39 EST (History)
6 users (show)

See Also:
Fixed In Version: 2.0.0-1.2.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 20:14:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 47890 None None None Never

  None (edit)
Description Dave Malcolm 2005-09-26 20:30:00 EDT
Description of problem:
I'm trying to see the various openoffice apps using the accessibility tools and
failing.

Version-Release number of selected component (if applicable):
openoffice.org-writer-1.9.128-2.2.0.fc5
openoffice.org-impress-1.9.128-2.2.0.fc5
openoffice.org-core-1.9.128-2.2.0.fc5

How reproducible:
100%

Steps to Reproduce:
1.  Ensure accessibility support is enabled for the user (logging out and then
back in if necessary)
2.  Start OO.org Writer
3.  Start at-poke (locally built, though the package is in Extras)
  
Actual results:
OO.org apps aren't visible in at-poke (all of the other apps running are, as far
as I can tell)

Expected results:
OO.org ought to be visible to at-poke
Comment 1 Caolan McNamara 2005-09-29 05:56:53 EDT
my understanding is that OOo needs the gnome java access bridge to get
accessibility off the ground. Now with gcj and so forth I think we should 

a) get java-access-bridge from gnome working with gcj
b) give it a whirl to see this will all work with gcj and friends
Comment 2 Caolan McNamara 2005-09-29 07:55:01 EDT
I'm informed that the java solution which is the default accessibility story for
OOo is fairly horrible, and that there is an alternative native atk solution in
the works. This solution sounds like the better long-term solution rather than
the java bridge hackery.
Comment 3 Caolan McNamara 2005-09-29 13:12:06 EDT
screw the java solution, lets try out the experimental native one.
Comment 4 Caolan McNamara 2005-10-01 15:07:31 EDT
should work in next rawhide release, if compiler doesn't throw another another
of its little fits.
Comment 5 Dave Malcolm 2005-10-03 17:59:57 EDT
Works for me with openoffice.org-writer 1:2.0.0-1.2.2

Awesome - thanks!
Comment 6 Zack Cerza 2005-12-01 14:30:41 EST
It's not working here - openoffice.org-writer-2.0.1-0.142.3.2.i386 on an x86_64.
Comment 7 Caolan McNamara 2005-12-01 14:35:41 EST
Try on a 32bit machine, OOo is 32bit, even on 64. If it's a 64bit only problem
then it's not a OOo problem, but a more general one.
Comment 8 Caolan McNamara 2005-12-02 09:27:30 EST
With most recent OOo 2.0.1-143.1.2 in i386 and with accessibility enabled, i.e. 

> gconftool-2 -g "/desktop/gnome/interface/accessibility"

says "true" and on running "at-poke" then soffice.bin is listed and responds to
at-poke. So seems to work fine for i386.
Comment 9 Zack Cerza 2005-12-02 13:51:22 EST
OK, it still doesn't work with those packages.

zcerza@tallest ~ =) % oowriter
Gtk-Message: Failed to load module "gail": libgail.so: cannot open shared object
file: No such file or directory
Gtk-Message: Failed to load module "atk-bridge": libatk-bridge.so: cannot open
shared object file: No such file or directory
<break>
zcerza@tallest ~ =) % sudo yum -y install at-spi.i386 gail.i386
...
No Match for argument: at-spi.i386
...
Installed: gail.i386 0:1.8.8-1

zcerza@tallest ~ =) % oowriter
Gtk-Message: Failed to load module "atk-bridge": libatk-bridge.so: cannot open
shared object file: No such file or directory

...And so it is still not accessible. We need at-spi.i386 and probably
ligail-gnome.i386 for it to work. Reopening and reassigning to comps.
Comment 10 Zack Cerza 2005-12-02 13:52:38 EST
Reassigning to default owner.
Comment 11 Nalin Dahyabhai 2005-12-05 19:29:04 EST
I can reproduce this on my x86_64 system and can confirm that installing at-spi,
gail, and libgail-gnome fixes it.
Comment 13 Jeremy Katz 2006-01-09 18:37:57 EST
Putting them in comps causes problems, though, due to things requiring
libgail-gnome.  This pulls in the 64bit libgail-gnome on a 64bit ppc machine
(eg, G5) which then pulls in a 64bit panel instead of the 32bit one.

We could fix this by splitting the panel libs into a subpackage or by making the
requirements on libgail-gnome understand arch.  The former is probably the easier
Comment 14 Dennis Gregorovic 2006-12-19 17:26:30 EST
Assigning back to Jesse.  I took it accidentally.
Comment 15 Red Hat Bugzilla 2007-02-05 14:14:04 EST
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.
Comment 16 Jesse Keating 2007-02-22 21:34:38 EST
To properly fix this, the suggestion from comment #13 needs to be done. 
Reassigning to libgail-gnome.
Comment 17 Bug Zapper 2008-04-03 12:24:30 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 18 Bug Zapper 2008-05-06 20:14:31 EDT
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

Note You need to log in before you can comment on or make changes to this bug.