Bug 175206 - OpenOffice.org is not accessible on x86_64
Summary: OpenOffice.org is not accessible on x86_64
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: comps   
(Show other bugs)
Version: 4.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
Depends On: 169323
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-12-07 19:05 UTC by Nalin Dahyabhai
Modified: 2011-12-13 20:26 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-13 20:26:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Comment 2 Mike McLean 2005-12-07 22:02:40 UTC
taking ownership

Comment 6 Daniel Riek 2006-03-13 23:27:41 UTC
The impact of this is high enough to carry forward the request to the next
Update. In addition it is not unlikely that there will be other requests for
this component possibly justifying a QA slot. 

Moving to the next Update, clearing all ACKs.


Comment 10 RHEL Product and Program Management 2006-07-21 16:43:59 UTC
Quality Engineering Management has reviewed and declined this request.  You may appeal this decision by reopening this request.

Comment 13 RHEL Product and Program Management 2006-08-18 16:53:40 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 15 Matthias Clasen 2006-09-01 00:46:37 UTC
To recap what I have learned so far:

1) oo is 32bit, and needs the 32bit at-spi, gail and libgail-gnome packages
   for a11y to work

2) installing the 64bit libbonobo breaks the desktop on ppc64

3) the first attempt at doing this was to add these packages to the "multilib
   list", this had the side-effect of causing the 64bit libbonobo to get
   installed

What is not clear to me is 

a) how the side-effect in 3) happens. Why do we even ship a 64bit libbonobo
   if installing it breaks the desktop ?

b) "Someone needs to fix the packages so that they play nice together" - it
   is not clear to me what packages are meant here. If anything, it seems we 
   need to find a way to get certain 32bit packages installed (at-spi, gail,
   libgail-gnome) without installing other 64bit packages (libbonobo) as
   a side-effect.

Comment 17 Mike McLean 2006-09-20 21:11:43 UTC
To answer a):
The compose expands the multiarch list to satisfy deps. The compat-arch [*]
libbonobo gets pulled in because some other compat-arch package needs it.
Leaving these dependencies out is likely to breaks things just as badly.

[*] - By compat-arch I mean the extra architecture in the compose for which we
include a basic subset of packages (mostly libraries). The compat-arch is not
always the smaller-bit-size arch. For x86_64 we have i386 as a compat-arch, but
on ppc we have ppc64 as the compat-arch.

What is slightly unclear to me is why bug#175533 only seems to crop up on ppc
(probably something to do with the asymmetry, sure, but what exactly).


Comment 22 RHEL Product and Program Management 2007-09-07 19:46:35 UTC
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.

Comment 23 Bill Nottingham 2011-12-13 20:26:44 UTC
This is not being fixed at this point in RHEL 4.


Note You need to log in before you can comment on or make changes to this bug.