Bug 169338 - date format changes on csv export from calc
date format changes on csv export from calc
Status: CLOSED DUPLICATE of bug 166664
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Depends On:
  Show dependency treegraph
Reported: 2005-09-27 03:06 EDT by Darren Cook
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-09-28 09:14:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Darren Cook 2005-09-27 03:06:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc4 Firefox/1.0.6

Description of problem:
The date format displayed on screen is not the one that gets saved to the file when I save as csv.

Attempted workarounds:
When I then tried changing the column type to text, it changed the fields to "38565" (for the 2005-08-01 example above) or similar. Weird.
I also tried loading the csv file in, altering the date format, saving to a new file, but same results.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Load an xls file into OpenOffice Calc
2.Select a column, right-click, choose format cells, choose date then 1999-12-31.
3.File|Save As, choose csv as the file type, and save.
4.View the csv file in a text editor.

Actual Results:  Dates appear in csv file as 08/01/2005 (they still show as 2005-08-01 in the Calc window)

Expected Results:  Date should appear as 2005-08-01

Additional info:
Comment 1 Caolan McNamara 2005-09-28 09:14:30 EDT

*** This bug has been marked as a duplicate of 166664 ***

Note You need to log in before you can comment on or make changes to this bug.