Bug 16937 - Abiword dumps core
Summary: Abiword dumps core
Status: CLOSED DUPLICATE of bug 13707
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: abiword (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-25 13:58 UTC by Mario Mikocevic
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-25 13:58:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mario Mikocevic 2000-08-25 13:58:52 UTC
danielle% uname -a
Linux danielle.hinet.hr 2.4.0-test5 #9 Pon Srp 31 15:41:45 CEST 2000 i686
unknown
danielle% rpm -qa | grep abiword
abiword-0.7.10-5
danielle% abiword 
/usr/X11R6/bin/abiword: line 39: 24452 Segmentation fault      (core
dumped) $ABISUITE_LIBEXEC/AbiWord_d "$@"

well strace is huge so I clipped some part that I think is relevant ->

...
uname({sys="Linux", node="danielle.hinet.hr", ...}) = 0
rt_sigprocmask(SIG_BLOCK, ~[], [CHLD TTOU], 8) = 0
rt_sigprocmask(SIG_SETMASK, [CHLD TTOU], NULL, 8) = 0
rt_sigprocmask(SIG_BLOCK, ~[], [CHLD TTOU], 8) = 0
rt_sigprocmask(SIG_SETMASK, [CHLD TTOU], NULL, 8) = 0
open("/usr/share/locale/hr_HR/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT
(No such file or directory)
open("/usr/share/locale/hr/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT (No
such file or directory)
write(2, "/usr/X11R6/bin/abiword: line 39:"..., 110/usr/X11R6/bin/abiword:
line 39: 24477 Segmentation fault      (core dumped)
$ABISUITE_LIBEXEC/AbiWord_d "$@"
) = 110
rt_sigprocmask(SIG_SETMASK, [CHLD TTOU], NULL, 8) = 0
rt_sigprocmask(SIG_SETMASK, [CHLD], NULL, 8) = 0
rt_sigprocmask(SIG_BLOCK, [CHLD], [CHLD], 8) = 0
rt_sigprocmask(SIG_SETMASK, [CHLD], NULL, 8) = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
--- SIGCHLD (Child exited) ---
...

--
mozgy

Comment 1 Bernhard Rosenkraenzer 2000-08-25 14:00:41 UTC

*** This bug has been marked as a duplicate of 13707 ***


Note You need to log in before you can comment on or make changes to this bug.