Bug 13707 - Programs do not Launch
Programs do not Launch
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: abiword (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Winston should-fix
:
: 15179 15822 16177 16937 (view as bug list)
Depends On:
Blocks: 14711
  Show dependency treegraph
 
Reported: 2000-07-11 08:32 EDT by Rogelio Noriega
Modified: 2008-05-01 11:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-18 01:53:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rogelio Noriega 2000-07-11 08:32:39 EDT
Issue: RedHat 7.0 (Winston)

System: PWS 620, SINGLE 933mhz, matrox g400 1536 RAM

Test Case: #12) 

2.) Abiword_d crashed due to a fatal error(GNOME) segmentation fault 
(process 20067)

Programs below do not launch when icon is selected.
--gPhoto does not work(i.e. no window or any activity on screen)
--gDict does not work
--gcharmap has crashed due to a fatal error
--xSane does not work
--xScanimage does not work
--XMixer does not work
Comment 1 Michael Redinger 2000-07-19 12:34:41 EDT
In addition to the "Abiword_d crashed due to a fatal error" entry:

AbiWord did start when I was working locally. However, when being logged in via
telnet (xhost and DISPLAY is ok) AbiWord immediately crashes with exactly this
message.
Comment 2 Bernhard Rosenkraenzer 2000-07-19 13:05:50 EDT
Please file this report against all the other packages you've listed as well -
other developers are responsible for them.
Comment 3 Rogelio Noriega 2000-07-27 09:00:58 EDT
Abiword_d still crashes in Beta 4
Comment 4 Tim Waugh 2000-07-28 05:24:46 EDT
Does 'abiword -nosplash' work?
Comment 5 Jos Vos 2000-07-30 11:18:29 EDT
AbiWord still won't start in Pinstripe due to a segfault.  Also, --nosplash
doesn't work either.
Comment 6 Glen Foster 2000-07-30 18:40:56 EDT
This defect is considered MUST-FIX for Winston Release-Candidate #1
Comment 7 Rogelio Noriega 2000-07-31 18:33:50 EDT
*Beta 5 did not fix the problem
Comment 8 Chris Evans 2000-07-31 18:52:39 EDT
Yep, BETA5 AbiWord hosed, won't even start up
Comment 9 Bernhard Rosenkraenzer 2000-08-02 13:06:59 EDT
Fixed - the problem was that libpng 1.0.8 is not binary compatible with 1.0.6
and doesn't increase the soname - and abiword was linked dynamically, compiled
with 1.0.6.
Comment 10 Bernhard Rosenkraenzer 2000-08-03 05:35:31 EDT
*** Bug 15179 has been marked as a duplicate of this bug. ***
Comment 11 Bernhard Rosenkraenzer 2000-08-09 11:13:46 EDT
*** Bug 15822 has been marked as a duplicate of this bug. ***
Comment 12 Jeremy Katz 2000-08-10 02:35:43 EDT
Still crashing in RC1 in XFree4.  It actually looks like the problem is that the
adding of the Abi font dir to the fontpath fails (xset fp+
/usr/share/AbiSuite/fonts as called in the AbiWord script gives the following)
	X Error of failed request:  86
	  Major opcode of failed request:  51 (X_SetFontPath)
	  Serial number of failed request:  9
	  Current serial number in output stream:  11

and then Abi can't load it's fonts and segfaults.  With no window manager
running, I actually don't get a segfault, and it pops up its window about being
unable to find its fonts.  Adding the Abi font dir to the default xfs font path
does allow AbiWord to start and run properly.
Comment 13 Bernhard Rosenkraenzer 2000-08-10 08:22:27 EDT
xset fp+ seems to be broken in XF4... Reassigning.
Comment 14 Bill Nottingham 2000-08-14 19:27:15 EDT
It's probably somewhat related to the fact that
re-running mkfontdir in the abi font directory
gives you no fonts in your fonts.dir. Are there
some missing files (fonts.alias, fonts.scale, perhaps?)
Comment 15 Preston Brown 2000-08-15 10:56:54 EDT
definitely an abiword problem.
Comment 16 Bill Nottingham 2000-08-15 11:31:18 EDT
Not really. xset +fp is failing for some bizarre reason.

However, the cleanest fix would really be for abiword
to call chkfontpath in %post/%preun, much like
the font packages themselves do. (It's also
easier to do this than to dig inside the X library
code...)
Comment 17 Bill Nottingham 2000-08-15 22:39:28 EDT
*** Bug 16177 has been marked as a duplicate of this bug. ***
Comment 18 Glen Foster 2000-08-16 18:43:45 EDT
This defect has been re-classified as SHOULD-FIX for Winston Gold-release
Comment 19 borgia 2000-08-18 01:53:14 EDT
AbiWord (RC1): OK in one install, also for users, and in one upgrade; fail in another upgrade
JFYI.
Comment 20 Preston Brown 2000-08-19 10:41:45 EDT
chkfontpath has been added.
Comment 21 Bernhard Rosenkraenzer 2000-08-25 10:00:38 EDT
*** Bug 16937 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.