Bug 1694097 - Redeployed cluster logging when nodeSelector changed for components
Summary: Redeployed cluster logging when nodeSelector changed for components
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: ewolinet
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-29 14:07 UTC by Anping Li
Modified: 2019-06-04 10:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:46:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:46:42 UTC
Github openshift cluster-logging-operator pull 143 None None None 2019-04-01 13:05:25 UTC
Github openshift elasticsearch-operator pull 114 None None None 2019-04-01 13:05:25 UTC

Description Anping Li 2019-03-29 14:07:03 UTC
Description of problem:

As a admin of openshift cluster, I want to the logging pod can be rescheduled once I change the ndoeSelector in clusterlogging resource file


Version-Release number of selected component (if applicable):
4.x

How reproducible:
Always

Steps to Reproduce:
1. Deploy cluster logging via cluster-logging-operator
2. Provide instance CR 
  oc create -f https://github.com/openshift-qe/v3-testfiles/blob/master/logging/clusterlogging/nodeSelector.yaml 
3. Change the nodeSelector in CR. For example: change the nodeSelector to logging=es2. 

Actual results:
The clusterlogging pods aren't redeployed.

Expected results:
The clusterlogging pods are redeployed.


Additional info:

Comment 1 Rich Megginson 2019-03-29 14:12:24 UTC
right - you have to set the clusterlogging managementState to Unmanaged

Comment 5 Jeff Cantrill 2019-04-01 13:03:56 UTC
*** Bug 1694511 has been marked as a duplicate of this bug. ***

Comment 6 Jeff Cantrill 2019-04-01 13:05:26 UTC
Node selector changes or any of the components should cause them to be redeployed.

Comment 9 errata-xmlrpc 2019-06-04 10:46:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.