Bug 1694511 - Redeployed cluster logging when nodeSelector changed in CLO
Summary: Redeployed cluster logging when nodeSelector changed in CLO
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: ewolinet
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-01 01:22 UTC by Anping Li
Modified: 2019-06-04 10:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:46:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:46:47 UTC

Description Anping Li 2019-04-01 01:22:39 UTC
Description of problem:
The pod should be redeployed once the nodeSelector is changed in CLO CR. That is the following of a https://bugzilla.redhat.com/show_bug.cgi?id=1694097



Version-Release number of selected component (if applicable):
4.x

How reproducible:
Always

Steps to Reproduce:
1. Deploy cluster logging via cluster-logging-operator
2. Provide instance CR 
  oc create -f https://github.com/openshift-qe/v3-testfiles/blob/master/logging/clusterlogging/nodeSelector.yaml 
3. Change the nodeSelector in CR.
For example: change the fluentd nodeSelector from logging=fluentd to logging=fluentd1
For example: change the kibana nodeSelector from logging=kibana to logging=kibana1


Actual results:
The clusterlogging pods aren't redeployed.

Expected results:
The clusterlogging pods are redeployed.


Additional info:

Comment 1 Jeff Cantrill 2019-04-01 13:03:56 UTC
Closing in favor of https://bugzilla.redhat.com/show_bug.cgi?id=1694097 as work is required in both operators to support the fix

*** This bug has been marked as a duplicate of bug 1694097 ***

Comment 7 errata-xmlrpc 2019-06-04 10:46:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.