Bug 169419 - language-support did not get installed
language-support did not get installed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
: i18n
: 175905 178104 (view as bug list)
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2005-09-28 01:59 EDT by Lawrence Lim
Modified: 2014-03-25 20:52 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 17:31:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lawrence Lim 2005-09-28 01:59:00 EDT
Description of problem:
Tried to install fresh rawhide-20050927 with zh_TW locale with language-support
checked. Noticed that after installation completes, all the necessary packages
listed in comps for chinese support were not installed. As the Input Method was
not installed, I was not able to input anything in Chinese.

Version-Release number of selected component (if applicable):
anaconda-runtime-10.3.0.25-1.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1.install rawhide with zh_TW lang
2.check language support
3.
  
Actual results:
All the packages necessary for Chinese env was not installed

Expected results:
All packages installed.

Additional info:
    <langonly>zh</langonly>
    <packagelist>
      <packagereq type="default">bg5ps</packagereq>
      <packagereq type="optional" requires="xorg-x11">scim-pinyin</packagereq>
      <packagereq type="optional" requires="xorg-x11">scim-chewing</packagereq>
      <packagereq type="optional" requires="kdelibs">scim-qtimm</packagereq>
      <packagereq type="optional" requires="kdelibs">kde-i18n-Chinese</packagereq>
      <packagereq type="optional"
requires="kdelibs">kde-i18n-Chinese-Big5</packagereq>
      <packagereq type="optional">stardict</packagereq>
      <packagereq type="mandatory">taipeifonts</packagereq>
      <packagereq type="mandatory">fonts-chinese</packagereq>
      <packagereq type="optional"
requires="openoffice.org-core">openoffice.org-langpack-zh_CN</packagereq>
      <packagereq type="optional"
requires="openoffice.org-core">openoffice.org-langpack-zh_TW</packagereq>
    </packagelist>
  </group>
Comment 1 Jeremy Katz 2005-09-28 08:51:57 EDT
Yes, we know :)  Per the package selection screen, we're completely overhauling
the way that package/group selection works which entails having stuff broken for
a little bit
Comment 2 Nerijus Baliūnas 2005-10-24 20:06:02 EDT
In FC3 SUPPORTED line in /etc/sysconfig/i18n includes all languages I selected  
during installation, but in FC4 only en_US. Is it intended? 
Comment 3 David Cantrell 2006-01-17 15:38:59 EST
*** Bug 178104 has been marked as a duplicate of this bug. ***
Comment 4 Chris Lumens 2006-01-17 16:03:39 EST
*** Bug 175905 has been marked as a duplicate of this bug. ***
Comment 5 Jens Petersen 2006-01-18 22:06:42 EST
This is fixed now as of fc5test2 afaik.

Note You need to log in before you can comment on or make changes to this bug.