Bug 1694229 - [v2v] [RFE] Conversion VM/host identification and deployment from CloudForms
Summary: [v2v] [RFE] Conversion VM/host identification and deployment from CloudForms
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: V2V
Version: 5.10.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: GA
: 5.10.4
Assignee: Brett Thurber
QA Contact: Yadnyawalk Tale
Red Hat CloudForms Documentation
URL:
Whiteboard: v2v
: 1705738 (view as bug list)
Depends On: 1622728
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-29 20:11 UTC by Satoe Imaishi
Modified: 2019-05-21 05:47 UTC (History)
12 users (show)

Fixed In Version: 5.10.4.2
Doc Type: Enhancement
Doc Text:
Clone Of: 1622728
Environment:
Last Closed: 2019-05-21 05:46:54 UTC
Category: ---
Cloudforms Team: V2V
Target Upstream Version:


Attachments (Terms of Use)
automation.log (5.23 KB, text/plain)
2019-05-06 16:18 UTC, Yadnyawalk Tale
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:1247 None None None 2019-05-21 05:47:01 UTC

Comment 2 CFME Bot 2019-03-29 20:30:49 UTC
New commits detected on ManageIQ/manageiq/hammer:

https://github.com/ManageIQ/manageiq/commit/48dbd21a87b5af4caf6a9ce43a9892d614228384
commit 48dbd21a87b5af4caf6a9ce43a9892d614228384
Author:     Adam Grare <agrare@redhat.com>
AuthorDate: Mon Nov 26 14:26:22 2018 -0500
Commit:     Adam Grare <agrare@redhat.com>
CommitDate: Mon Nov 26 14:26:22 2018 -0500

    Merge pull request #18232 from djberg96/supports_conversion_host

    Add conversion_host option to the SupportsFeatureMixin module

    (cherry picked from commit c9d1e4d6d7e1b52a8bf19687918e844d924909ec)

    https://bugzilla.redhat.com/show_bug.cgi?id=1694229

 app/models/mixins/supports_feature_mixin.rb | 1 +
 1 file changed, 1 insertion(+)


https://github.com/ManageIQ/manageiq/commit/373368e38ce4f7c40b6e88e676c1473b18515838
commit 373368e38ce4f7c40b6e88e676c1473b18515838
Author:     Adam Grare <agrare@redhat.com>
AuthorDate: Tue Dec 11 14:15:21 2018 -0500
Commit:     Adam Grare <agrare@redhat.com>
CommitDate: Tue Dec 11 14:15:21 2018 -0500

    Merge pull request #18277 from djberg96/conversion_host_validations2

    Add ConversionHost validations

    (cherry picked from commit c6174684c548dc78120ab21ff2725d8f00a70bec)

    https://bugzilla.redhat.com/show_bug.cgi?id=1694229

 app/models/conversion_host.rb | 22 +-
 spec/models/conversion_host_spec.rb | 10 +-
 spec/models/service_template_transformation_plan_task_spec.rb | 2 +-
 3 files changed, 23 insertions(+), 11 deletions(-)


https://github.com/ManageIQ/manageiq/commit/135db80dbb8e7559fbf32fe74750d017f677d1f4
commit 135db80dbb8e7559fbf32fe74750d017f677d1f4
Author:     Adam Grare <agrare@redhat.com>
AuthorDate: Thu Jan 17 09:05:16 2019 -0500
Commit:     Adam Grare <agrare@redhat.com>
CommitDate: Thu Jan 17 09:05:16 2019 -0500

    Merge pull request #18323 from djberg96/conversion_host_ansible_playbook

    Alter ansible_playbook method so that some arguments are optional

    (cherry picked from commit 658581253e0b061eb3266e5d2030b6f391d08ea6)

    https://bugzilla.redhat.com/show_bug.cgi?id=1694229

 app/models/conversion_host.rb | 18 +-
 1 file changed, 9 insertions(+), 9 deletions(-)


https://github.com/ManageIQ/manageiq/commit/611964aefa0bf7c72af7309ffd0ba0a3db715d44
commit 611964aefa0bf7c72af7309ffd0ba0a3db715d44
Author:     Adam Grare <agrare@redhat.com>
AuthorDate: Thu Jan 31 13:54:37 2019 -0500
Commit:     Adam Grare <agrare@redhat.com>
CommitDate: Thu Jan 31 13:54:37 2019 -0500

    Merge pull request #18419 from djberg96/conversion_host_configurations2

    Simplify the ConversionHost::Configurations#enable method.

    (cherry picked from commit 8d33fa57a6f3dba5946be73c02ff23505e4ec20c)

    https://bugzilla.redhat.com/show_bug.cgi?id=1694229

 app/models/conversion_host/configurations.rb | 13 +-
 spec/models/conversion_host/configurations_spec.rb | 10 +-
 2 files changed, 8 insertions(+), 15 deletions(-)

Comment 3 CFME Bot 2019-03-29 20:36:53 UTC
New commit detected on ManageIQ/manageiq-providers-ovirt/hammer:

https://github.com/ManageIQ/manageiq-providers-ovirt/commit/618cefad991ad7b3219a35a55bd0081fdef862e2
commit 618cefad991ad7b3219a35a55bd0081fdef862e2
Author:     Adam Grare <agrare@redhat.com>
AuthorDate: Tue Feb  5 13:15:21 2019 -0500
Commit:     Adam Grare <agrare@redhat.com>
CommitDate: Tue Feb  5 13:15:21 2019 -0500

    Merge pull request #315 from djberg96/supports_conversion_host

    Add supports_conversion_host to Host

    (cherry picked from commit 37e9e07055d309134ca6d02cea305ea3fdfb3229)

    https://bugzilla.redhat.com/show_bug.cgi?id=1694229

 app/models/manageiq/providers/redhat/infra_manager/host.rb | 8 +
 spec/models/manageiq/providers/redhat/infra_manager/host_spec.rb | 14 +
 2 files changed, 22 insertions(+)

Comment 4 CFME Bot 2019-03-29 20:36:58 UTC
New commit detected on ManageIQ/manageiq-providers-openstack/hammer:

https://github.com/ManageIQ/manageiq-providers-openstack/commit/1de7b35994a4b5da7a923a91983688a7504e9de8
commit 1de7b35994a4b5da7a923a91983688a7504e9de8
Author:     Samuel Lucidi <mansam@csh.rit.edu>
AuthorDate: Mon Dec  3 12:39:46 2018 -0500
Commit:     Samuel Lucidi <mansam@csh.rit.edu>
CommitDate: Mon Dec  3 12:39:46 2018 -0500

    Merge pull request #407 from djberg96/supports_conversion_host

    Add supports_conversion_host to Vm

    (cherry picked from commit 75c73724e034c062566ac789323bcf7c1d691ec5)

    https://bugzilla.redhat.com/show_bug.cgi?id=1694229

 app/models/manageiq/providers/openstack/cloud_manager/vm.rb | 1 +
 spec/models/manageiq/providers/openstack/cloud_manager/vm_spec.rb | 6 +
 2 files changed, 7 insertions(+)

Comment 5 Satoe Imaishi 2019-04-01 15:35:13 UTC
6 PRs backported to Hammer branch (Comment2, Comment3 and Comment4) are reverted.

Comment 6 Fabien Dupont 2019-04-18 20:14:50 UTC
Run the playbook on the appliance with the conversion host in inventory - https://github.com/ManageIQ/manageiq/pull/18613

Satoe, we should be good to backport.

Comment 11 CFME Bot 2019-04-24 19:47:05 UTC
New commit detected on ManageIQ/manageiq/hammer:

https://github.com/ManageIQ/manageiq/commit/0ad2ae96799a0ef296699e1878a8e29ba31792cf
commit 0ad2ae96799a0ef296699e1878a8e29ba31792cf
Author:     Adam Grare <agrare@redhat.com>
AuthorDate: Wed Mar 13 10:27:45 2019 -0400
Commit:     Adam Grare <agrare@redhat.com>
CommitDate: Wed Mar 13 10:27:45 2019 -0400

    Merge pull request #18537 from fdupont-redhat/v2v_generate_ansible_extra_vars

    [V2V] Generate extra vars for conversion host playbooks

    (cherry picked from commit 6e9428fc5678fc11a3f531a1d693df97bfc35242)

    https://bugzilla.redhat.com/show_bug.cgi?id=1694229

 app/models/conversion_host.rb | 26 +-
 app/models/conversion_host/configurations.rb | 7 +-
 spec/models/conversion_host/configurations_spec.rb | 39 +-
 3 files changed, 45 insertions(+), 27 deletions(-)

Comment 12 CFME Bot 2019-04-25 13:26:02 UTC
New commits detected on ManageIQ/manageiq/hammer:

https://github.com/ManageIQ/manageiq/commit/14d5c668d3ad382b71ea02f14e833ac3cdc772a6
commit 14d5c668d3ad382b71ea02f14e833ac3cdc772a6
Author:     Adam Grare <agrare@redhat.com>
AuthorDate: Thu Apr 18 12:58:56 2019 -0400
Commit:     Adam Grare <agrare@redhat.com>
CommitDate: Thu Apr 18 12:58:56 2019 -0400

    Merge pull request #18613 from fdupont-redhat/v2v_conversion_host_playbook

    [V2V] Run the playbook on the appliance with the conversion host in inventory

    (cherry picked from commit 1a2f07f84a71c88dfdcd2cec936b7aba4e9f768b)

    https://bugzilla.redhat.com/show_bug.cgi?id=1694229

 app/models/conversion_host.rb | 75 +-
 app/models/conversion_host/configurations.rb | 6 +-
 spec/models/conversion_host_spec.rb | 94 +-
 3 files changed, 149 insertions(+), 26 deletions(-)

Comment 14 Yadnyawalk Tale 2019-05-06 14:35:19 UTC
We are able to successfully configure and migrate VM via conversion UI for RHV.
We are working with OSP usecase, if that is successful, we can close BZ1705738 and verify this issue.

Tested on CFME: 5.10.4.1.20190430152139_40a1d86
RHV 4.3

Comment 15 Yadnyawalk Tale 2019-05-06 16:10:59 UTC
*** Bug 1705738 has been marked as a duplicate of this bug. ***

Comment 16 Yadnyawalk Tale 2019-05-06 16:18:14 UTC
Created attachment 1564605 [details]
automation.log

I have configured OSP conversion instance successfully but while migration it failed with attached errors.
I did not setuped anything on conversion instance this time since I heard cloudforms itself responsible to run playbook (earlier, to run ansible playbook I was adding inventory on instance).

Marking failedQA since migration failed, let us know if we need to setup anything on conversion instance before running migration.

Used solution engineering's OSP14 and vCenter
Tested on: 5.10.4.1.20190430152139_40a1d86 
Used conversion image: rhosp-v2v-appliance-14.0-20190424.2 (latest https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=886627)
conversion wrapper on instance: v2v-conversion-host-wrapper-1.12.1-5.el7ev.noarch
VDDK url used: http://file.rdu.redhat.com/~kkulkarn/VMware-vix-disklib-6.7.1-10362358.x86_64.tar.gz 
private key: v2v-qe-lab.pem (attached)

Comment 18 Yadnyawalk Tale 2019-05-06 16:34:51 UTC
Just FYI, I have used full key with attributes while using RHV conversion host, whereas for OSP it is normal private key.

Comment 19 Daniel Berger 2019-05-06 17:07:52 UTC
I see the problem. It was trying to get at the default credentials for the resource, but for OSP it should default to the EMS authentication.

I've included the fix as part of this PR:

https://github.com/ManageIQ/manageiq/pull/18724

Comment 20 Yadnyawalk Tale 2019-05-07 16:11:41 UTC
We have tested patch mentioned in Comment #19 and it worked after adding osp provider with SSL. Good to go for next CFME build.

Comment 21 CFME Bot 2019-05-08 01:20:45 UTC
New commit detected on ManageIQ/manageiq/hammer:

https://github.com/ManageIQ/manageiq/commit/e9beef70e978a6ec75feb376c5cc691e81fb20b1
commit e9beef70e978a6ec75feb376c5cc691e81fb20b1
Author:     Adam Grare <agrare@redhat.com>
AuthorDate: Tue May  7 19:58:11 2019 -0400
Commit:     Adam Grare <agrare@redhat.com>
CommitDate: Tue May  7 19:58:11 2019 -0400

    Merge pull request #18724 from djberg96/conversion_host_ansible_playbook_default_credentials

    [V2V] Add default credentials to ansible_playbook method

    (cherry picked from commit a68811eee56fc4a7bc632c4b74f8c64c0e5b6ef0)

    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1694229

 app/models/conversion_host.rb | 27 +-
 1 file changed, 15 insertions(+), 12 deletions(-)

Comment 22 Yadnyawalk Tale 2019-05-08 07:17:15 UTC
I tested patch https://github.com/ManageIQ/manageiq/commit/e9beef70e978a6ec75feb376c5cc691e81fb20b1 by adding it manually over 5.10.4.1 with SSL setup and conversion still giving `Error: [Unknown auth type: ssh_keypair]` error in evm and it is not getting configured for OSP.

On Notification side we are getting `Conversion Host enable of resource type=VmOrTemplate id=177 failed. Please check the logs for further details.` error.
Tested on: https://10.8.197.182

Comment 23 Yadnyawalk Tale 2019-05-08 16:32:41 UTC
We have tested it again with 5.10.4 (without any patch) and conversion configuration works when we add SSH private key on configuration itself and not while adding provider.
So as a result we can revert/unbackport comment #21 patch and we can move this issue to VERIFIED.

Many thanks to fabien and daniel for help.

Comment 24 CFME Bot 2019-05-08 16:50:52 UTC
New commit detected on ManageIQ/manageiq/hammer:

https://github.com/ManageIQ/manageiq/commit/282f74ed07d2f851110d9b3d9a5428f1fa7a79ef
commit 282f74ed07d2f851110d9b3d9a5428f1fa7a79ef
Author:     Satoe Imaishi <simaishi@redhat.com>
AuthorDate: Wed May  8 12:46:48 2019 -0400
Commit:     Satoe Imaishi <simaishi@redhat.com>
CommitDate: Wed May  8 12:46:48 2019 -0400

    Revert "Merge pull request #18724 from djberg96/conversion_host_ansible_playbook_default_credentials"

    This reverts commit e9beef70e978a6ec75feb376c5cc691e81fb20b1.

    https://bugzilla.redhat.com/show_bug.cgi?id=1694229

 app/models/conversion_host.rb | 27 +-
 1 file changed, 12 insertions(+), 15 deletions(-)

Comment 25 Yadnyawalk Tale 2019-05-09 17:13:49 UTC
Fixed! Verifying issue since I can add conversion host of RHV and OSP both via SSH and VDDK methods in UI.

Please note, end to end migration is not working with SSH for both RHV & OSP (https://bugzilla.redhat.com/show_bug.cgi?id=1707983) and with VDDK it is not working for OSP (https://bugzilla.redhat.com/show_bug.cgi?id=1708359), tracking both issue in separate BZs.

Tested on: 5.10.4.2.20190508174256_282f74e

Comment 26 Shveta 2019-05-09 20:36:00 UTC
Failing QE as OSP with VDDK and SSH failed .

Comment 27 Fabien Dupont 2019-05-09 20:43:52 UTC
I don't see why it's not verified. The feature is complete as we can enable the conversion host. The fact that it misses some information should be addressed in a separate BZ.

Comment 28 Shveta 2019-05-10 01:57:12 UTC
Ok verifying based on above comments .
There are Bz's tracking OSP migration failure .

Comment 30 errata-xmlrpc 2019-05-21 05:46:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1247


Note You need to log in before you can comment on or make changes to this bug.