Bug 1705738 - Unable to add conversion host through UI
Summary: Unable to add conversion host through UI
Keywords:
Status: CLOSED DUPLICATE of bug 1694229
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: V2V
Version: 5.10.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: GA
: 5.10.4
Assignee: Fabien Dupont
QA Contact: Shveta
Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-02 20:39 UTC by Shveta
Modified: 2019-05-06 16:10 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-06 16:10:59 UTC
Category: ---
Cloudforms Team: V2V
Target Upstream Version:


Attachments (Terms of Use)
Video of the issue (2.81 MB, video/webm)
2019-05-02 20:39 UTC, Shveta
no flags Details

Description Shveta 2019-05-02 20:39:43 UTC
Created attachment 1561985 [details]
Video of the issue

Description of problem:


Version-Release number of selected component (if applicable):
5.10.4.1.20190430152139_40a1d86

How reproducible:


Steps to Reproduce:
1. Add Vmware and RHV. 
2. Conversion Host UI (Migration settings - conversion host)
3. FIll the form and submit . Request always fails .

SSH KEY is /etc/pki/ovirt-engine/keys/engine_id_rsa from RHEV managaer.

Actual results:


Expected results:


Additional info:
Appliance : https://10.8.196.159

Comment 2 Shveta 2019-05-02 20:47:26 UTC
puts MiqTask.where(MiqTask.arel_table[:name].matches('%operation=enable resource=(name: env-rhv42-02.cfme2.lab.eng.rdu2.redhat.com%')).last.context_data['conversion_host_enable']

PLAY [Enable conversion host role] *********************************************

TASK [Gathering Facts] *********************************************************
fatal: [env-rhv42-02.cfme2.lab.eng.rdu2.redhat.com]: UNREACHABLE! => {"changed": false, "msg": "Failed to connect to the host via ssh: Permission denied (publickey,gssapi-keyex,gssapi-with-mic,password).", "unreachable": true}
	to retry, use: --limit @/usr/share/v2v-conversion-host-ansible/playbooks/conversion_host_enable.retry

PLAY RECAP *********************************************************************
env-rhv42-02.cfme2.lab.eng.rdu2.redhat.com : ok=0    changed=0    unreachable=1    failed=0   

=> nil

Comment 3 Shveta 2019-05-02 20:48:04 UTC
I think something to do with ssh key content/format.

Comment 5 Sudhir Mallamprabhakara 2019-05-05 04:21:18 UTC
changing the target release to 5.10.4

@Shveta - Please re-test.. https://bugzilla.redhat.com/show_bug.cgi?id=1705738#c4

- Sudhir

Comment 6 Yadnyawalk Tale 2019-05-06 14:34:23 UTC
We are able to successfully configure and migrate VM via conversion UI for RHV.
We are working with OSP usecase, if that is successful, we can close this issue and verify BZ1694229.

Tested on CFME: 5.10.4.1.20190430152139_40a1d86
RHV 4.3

Comment 7 Yadnyawalk Tale 2019-05-06 16:10:59 UTC

*** This bug has been marked as a duplicate of bug 1694229 ***


Note You need to log in before you can comment on or make changes to this bug.