Bug 169423 - initscripts - a typo is really messing up networks
Summary: initscripts - a typo is really messing up networks
Status: CLOSED DUPLICATE of bug 169359
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-09-28 07:14 UTC by Michal Jaegermann
Modified: 2014-03-17 02:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 17:49:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2005-09-28 07:14:08 UTC
Description of problem:

An obvious typo in /etc/sysconfig/network-scripts/network-functions (here)

@@ -220,7 +220,7 @@
     hostname $1
     if ! grep search /etc/resolv.conf >/dev/null 2>&1; then
 	domain=`echo $1 | sed 's/^[^\.]*\.//'`
-	if [ -n "$domain" ]; thenb
+	if [ -n "$domain" ]; then
 		rsctmp=`mktemp /tmp/XXXXXX`;
 		cat /etc/resolv.conf > $rsctmp
 		echo "search $domain" >> $rsctmp

really makes a mincemeat from  networking.  On startup, but even worse
on shutdown.

Version-Release number of selected component (if applicable):
initscripts-8.15-1

Comment 1 Bill Nottingham 2005-09-28 17:49:21 UTC

*** This bug has been marked as a duplicate of 169359 ***


Note You need to log in before you can comment on or make changes to this bug.