Bug 1695328 - Unit test flake post rebase: TestIntermittentConnectionLoss
Summary: Unit test flake post rebase: TestIntermittentConnectionLoss
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Master
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.1.0
Assignee: Michal Fojtik
QA Contact: Xingxing Xia
URL:
Whiteboard:
: 1695260 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-02 20:14 UTC by Clayton Coleman
Modified: 2019-06-04 10:47 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:47:10 UTC

Description Clayton Coleman 2019-04-02 20:14:39 UTC
https://openshift-gce-devel.appspot.com/build/origin-ci-test/pr-logs/pull/22455/pull-ci-openshift-origin-master-unit/4554#githubcomopenshiftoriginvendork8sioapiserverpkgstoragevalueencryptenvelope-testintermittentconnectionloss

=== RUN   TestIntermittentConnectionLoss
E0402 19: ...
				
=== RUN   TestIntermittentConnectionLoss
E0402 19:29:50.103053   17587 grpc_service.go:71] failed to create connection to unix socket: @kms-socket.sock, error: dial unix @kms-socket.sock: connect: connection refused
--- FAIL: TestIntermittentConnectionLoss (1.02s)
	grpc_service_unix_test.go:93: Connected to KMSPlugin
	grpc_service_unix_test.go:97: KMS Plugin is stopped
	grpc_service_unix_test.go:104: Sending encrypt request
	grpc_service_unix_test.go:108: failed when executing encrypt, error: rpc error: code = Unavailable desc = transport is closing
	grpc_service_unix_test.go:120: Restarted KMS Plugin

Failing very frequently.

Comment 1 Michal Fojtik 2019-04-03 09:34:56 UTC
Attemptto fix: https://github.com/openshift/origin/pull/22463

Comment 2 Michal Fojtik 2019-04-03 13:34:32 UTC
*** Bug 1695260 has been marked as a duplicate of this bug. ***

Comment 3 Michal Fojtik 2019-04-05 09:45:10 UTC
https://github.com/openshift/origin/pull/22463 merged, moving to QA.

Comment 4 Xingxing Xia 2019-04-08 09:32:36 UTC
Moving to VERIFIED because TestIntermittentConnectionLoss passed per https://openshift-gce-devel.appspot.com/builds/origin-ci-test/pr-logs/pull/22463/pull-ci-openshift-origin-master-unit/ runs' results.

Comment 6 errata-xmlrpc 2019-06-04 10:47:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.