Bug 1695378 - Update syspurpose status handling to match Candlepin
Summary: Update syspurpose status handling to match Candlepin
Keywords:
Status: CLOSED DUPLICATE of bug 1695379
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hosts - Content
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Stephen Wadeley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-03 00:39 UTC by Jonathon Turel
Modified: 2019-04-16 14:58 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-16 14:58:11 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jonathon Turel 2019-04-03 00:39:34 UTC
Candlepin has been updated to change reporting around syspurpose status: https://github.com/candlepin/candlepin/pull/2194/files

- Invalid is now Mismatched
- Valid is now Matched

Above two changes affect host search ie "sla_status = invalid" is now "sla_status = mismatched" same for purpose_status, role_status, usage_status, addons_status

- Not Specified (new)

New hosts will no longer show "Matched" on content host details but rather "Not Specified" Hosts without any purpose attributes set will show Not Specified

Summary of what the statuses mean, from Candlepin code:

    /*
     * The status is 'Matched' if at least one syspurpose attribute (SLA, role, addons, usage) is specified,
     * and all of those that are specified are satisfied by the consumer's entitlements.
     *
     * The status is 'Mismatched' if at least one syspurpose attribute (SLA, role, addons, usage)
     * is specified, and from those specified, at least one is not satisfied by the consumer's entitlements.
     * (This includes the scenario of multiple addons being specified, where only some but not all of them
     * are satisfied)
     *
     * The status is 'Not Specified' when NONE of the attributes were specified by the consumer at all.
     */

Comment 3 Brad Buckingham 2019-04-16 14:58:11 UTC

*** This bug has been marked as a duplicate of bug 1695379 ***


Note You need to log in before you can comment on or make changes to this bug.