Bug 169581 - HTTP perhaps ought to be the explicit default protocol
Summary: HTTP perhaps ought to be the explicit default protocol
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora Documentation
Classification: Fedora
Component: docs-requests (Show other bugs)
(Show other bugs)
Version: devel
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Paul W. Frields
QA Contact: Karsten Wade
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 130125
TreeView+ depends on / blocked
 
Reported: 2005-09-29 20:47 UTC by Stuart Ellis
Modified: 2009-07-07 04:09 UTC (History)
2 users (show)

Fixed In Version: 0.33
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-16 23:57:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stuart Ellis 2005-09-29 20:47:08 UTC
Description of problem:

Tutorial currently doesn't specify a setup process for the network sharing
service, but the default directory is the FTP directory, which is not accessible
to Apache by default.

Fedora mirrors may be internal to sites/home networks/test labs, or even local
to machines to enable building OS installations for Xen or Kadishi. In these
cases HTTP may be preferrable, as it is more secure and considerably easier to
set up than NFS or FTP. In many cases, Apache is likely to already be active on
the local server.

Public mirrors (the less common use case) may have different considerations...

If it's helpful, please feel free to pull material from the document below (or I
can supply patches).

Additional info:

This (alpha) tutorial demonstrates configuring an local installation server,
using HTTP as the default file share protocol.

http://mythic-beasts.com/~hobb/fedora/installation-servers-en/

DocBook source:

http://mythic-beasts.com/~hobb/fedora/installation-servers-en.tar.gz

Comment 1 Paul W. Frields 2005-10-12 21:57:40 UTC
I was going to steal a smidge of your source, but the tarball noted here is of
generated HTML.  Can you provide another URL?  Thanks!

Comment 2 Stuart Ellis 2005-10-12 22:32:23 UTC
Sorry, uploaded the wrong tarball. Since the source is a single DocBook file,
I've posted it here as is:

http://mythic-beasts.com/~hobb/fedora/installation-servers-en.xml

Comment 3 Paul W. Frields 2005-10-16 23:57:34 UTC
I think this is now taken care of in the current beta tutorial, 0.33.

Comment 4 eric@christensenplace.us 2009-07-07 04:09:10 UTC
Ticket moved to allow products to be removed from BZ.


Note You need to log in before you can comment on or make changes to this bug.