Bug 169597 - I/O but deadlock with multiple snapshot
Summary: I/O but deadlock with multiple snapshot
Status: CLOSED DUPLICATE of bug 132057
Alias: None
Product: Fedora
Classification: Fedora
Component: lvm2
Version: 3
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Alasdair Kergon
QA Contact:
URL:
Whiteboard:
Keywords:
: 169598 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-09-30 02:13 UTC by Rocky Lee
Modified: 2007-11-30 22:11 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2005-10-03 15:28:42 UTC


Attachments (Terms of Use)

Description Rocky Lee 2005-09-30 02:13:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; KKman3.0)

Description of problem:
I/O but deadlock with multiple snapshot,

if there's more then 3 snapshot devices on one source volume.
then trying to put hundreds files to the source volume and sync.
the sync process will go to deep-sleep and can't wake up anymore.
daemon pdflush also goes to sleep..


Version-Release number of selected component (if applicable):
FC3 kernel and LVM2,  also test with 2.6.13 kernel has the same result

How reproducible:
Always

Steps to Reproduce:
1.create a source volume lv1.
2.create 3 snapshot volumes s1, s2, s3 with source lv1
3.copy all /usr/local files to the lv1
4.sync

or execute the following script

for i in 1 2 3 4 5 6; do
lvcreate -s -L 128 -n s${I} /dev/VG01/lv1
cp -af /etc /mnt/lv1
sync
sleep 5
done
  

Actual Results:  copy files to the source volume, then I/O process sleep...
can't sync files anymore... 

Expected Results:  success sync.

Additional info:

Comment 1 Rocky Lee 2005-09-30 02:21:27 UTC
*** Bug 169598 has been marked as a duplicate of this bug. ***

Comment 2 Alasdair Kergon 2005-10-03 15:28:42 UTC

*** This bug has been marked as a duplicate of 132057 ***


Note You need to log in before you can comment on or make changes to this bug.