Bug 169598 - I/O but deadlock with multiple snapshot
I/O but deadlock with multiple snapshot
Status: CLOSED DUPLICATE of bug 169597
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Alasdair Kergon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-29 22:13 EDT by Rocky Lee
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 22:21:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rocky Lee 2005-09-29 22:13:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; KKman3.0)

Description of problem:
I/O but deadlock with multiple snapshot,

if there's more then 3 snapshot devices on one source volume.
then trying to put hundreds files to the source volume and sync.
the sync process will go to deep-sleep and can't wake up anymore.
daemon pdflush also goes to sleep..


Version-Release number of selected component (if applicable):
FC3 kernel and LVM2,  also test with 2.6.13 kernel has the same result

How reproducible:
Always

Steps to Reproduce:
1.create a source volume lv1.
2.create 3 snapshot volumes s1, s2, s3 with source lv1
3.copy all /usr/local files to the lv1
4.sync

or execute the following script

for i in 1 2 3 4 5 6; do
lvcreate -s -L 128 -n s${I} /dev/VG01/lv1
cp -af /etc /mnt/lv1
sync
sleep 5
done
  

Actual Results:  copy files to the source volume, then I/O process sleep...
can't sync files anymore... 

Expected Results:  success sync.

Additional info:
Comment 1 Rocky Lee 2005-09-29 22:21:11 EDT

*** This bug has been marked as a duplicate of 169597 ***

Note You need to log in before you can comment on or make changes to this bug.