Bug 169619 - unnecessary ruby-libs dependency on tck/tk
Summary: unnecessary ruby-libs dependency on tck/tk
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ruby
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Bill Huang
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 195872
TreeView+ depends on / blocked
 
Reported: 2005-09-30 11:02 UTC by Ward Wouts
Modified: 2007-11-30 22:11 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2005-10-04 04:56:00 UTC


Attachments (Terms of Use)

Description Ward Wouts 2005-09-30 11:02:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc3 Firefox/1.0.6

Description of problem:
With the latest upgrade (ruby-libs-1.8.3-1.fc4.i386.rpm) the ruby-libs package started depending on tcl/tk. Any tcl/tk dependencies should be limited to the ruby-tcltk package.

Version-Release number of selected component (if applicable):
ruby-libs-1.8.3-1.fc4

How reproducible:
Always

Steps to Reproduce:
1. [ward@stromboli ward]$ rpm -qa|grep ruby
ruby-libs-1.8.2-7.fc4.2
ruby-1.8.2-7.fc4.2
2. [ward@stromboli ward]$ sudo rpm -Uhv ruby-libs-1.8.3-1.fc4.i386.rpm ruby-1.8.3-1.fc4.i386.rpm
ward@stromboli password:
warning: ruby-libs-1.8.3-1.fc4.i386.rpm: Header V3 DSA signature: NOKEY, key ID 4f2a6fd2
error: Failed dependencies:
        libtcl8.4.so is needed by ruby-libs-1.8.3-1.fc4.i386
        libtk8.4.so is needed by ruby-libs-1.8.3-1.fc4.i386


Actual Results:  Upgrade to newer ruby-libs package failed because of missing tcl/tk.

Expected Results:  The upgrade should just work.

Additional info:

Comment 1 Fedora Update System 2005-10-03 16:41:03 UTC
From User-Agent: XML-RPC

ruby-1.8.3-2.fc4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.