Bug 169652 - unhandled thread exception in wine-2005-930 locks up machine hard
unhandled thread exception in wine-2005-930 locks up machine hard
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-30 12:58 EDT by Joe Christy
Modified: 2015-01-04 17:22 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-04 21:38:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
WineDbg provided backtrace of wine page fault (6.92 KB, text/plain)
2005-11-15 15:03 EST, Joe Christy
no flags Details

  None (edit)
Description Joe Christy 2005-09-30 12:58:42 EDT
Description of problem:
running wine under kernel-2.6.13-1.1526 produces:
  wine: Unhandled exception (thread 0009), starting debugger...
and then locks up my machine hard - keyboard & screen dead, no remote ssh
access, must be power-cycled to proceed.


Version-Release number of selected component (if applicable):
kernel-2.6.13-1.1526

How reproducible:
every time

Steps to Reproduce:
1.launch wine
2.
3.
  
Actual results:
Within an instant the controlling shell (wrom whence wine was invoked) shows:
  wine: Unhandled exception (thread 0009), starting debugger...
and then locks up my machine hard - keyboard & screen dead, no remote ssh
access, must be power-cycled to proceed.


Expected results:
wine launches

Additional info:
Wine people say that this is a platform, rather than wine bug, cf.
http://bugs.winehq.org/show_bug.cgi?id=3416.

Running wine under gdb shows:
pequod(src) gdb wine
GNU gdb Red Hat Linux (6.3.0.0-1.21rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...Using host libthread_db
library "/lib/libthread_db.so.1".

(gdb) run
Starting program: /usr/local/bin/wine
Reading symbols from shared object read from target memory...done.
Loaded system supplied DSO at 0x154000
[Thread debugging using libthread_db enabled]
[New Thread -1209080128 (LWP 12264)]
[New Thread -1209082960 (LWP 12268)]
[Thread -1209082960 (LWP 12268) exited]
Cannot find user-level thread for LWP 12264: generic error

I know that it looks like a glibc-2.3.5-10.3 bug, but it does not appear on
another machine with the same glibc, but older kernel-2.6.12-1.1456 does not
display this bug.
Comment 1 julian 2005-10-20 15:04:07 EDT
i can confirm this bug on an up-to-date fc4 system, BUT it is possible to "rescue" the machine if you ARE 
already logged in per ssh and kill -9 all wine-related  processes. very annoying
Comment 2 julian 2005-10-27 11:37:06 EDT
still occurs with wine 0.9 and kernel 2.6.13-1.1532_FC4
Comment 3 Andreas Bierfert 2005-10-27 11:51:55 EDT
Are you using the wine rpm from winehq or some selfcompiled version?
Comment 4 Rudolf Kastl 2005-10-27 11:52:11 EDT
what about the same machine with an older kernel?
Comment 5 Joe Christy 2005-10-27 11:59:07 EDT
W/ a clean wine 0.9 built from CVS the morning of the 0.9 announcement, and
kernel 2.6.13-1.1532_FC4, on my two FC4 boxen, I never see this on one machine
(which has never displayed the problem, in fact), and intermittently on the other.

What is surpassingly strange, is that now, when I run wine under gdb on _either_
box, I _always_ see the behavior cited in my original comment.

Sigh, this one's a head-scratcher.
Comment 6 Andreas Bierfert 2005-10-27 12:03:01 EDT
Hm, mind to try my package? see bug 171526

I will upload a new revision including i386 asap...
Comment 7 julian 2005-10-27 12:19:13 EDT
>Are you using the wine rpm from winehq or some selfcompiled version?

RPMs from winehq, happens with:

wine-0.9-1fc4winehq.i686.rpm
and
wine-20050930-1fc4winehq.i686.rpm

as the original post says, winehq says this is a fedora and not a package/wine bug:
http://bugs.winehq.org/show_bug.cgi?id=3416
Comment 8 Andreas Bierfert 2005-10-27 12:29:04 EDT
Still strange... I thought I have been using 20050930 here as well without any
problems (I only use it to play diablo2 atm but anyway).
Currently uploading new version if you want give it a try...
Comment 9 julian 2005-10-27 12:35:36 EDT
>Currently uploading new version if you want give it a try...
if you give me a .ix86.rpm i can give it a try...dunno how to install a src.rpm let alone a .spec file ;->
Comment 10 Andreas Bierfert 2005-10-27 15:03:11 EDT
Sure here you go: just remember this package is under review for extras so don't
blame me ;) (see bug 171526)

http://fedora.lowlatency.de/review/i386/
Comment 11 julian 2005-10-27 16:55:39 EDT
hmm as far as i'm concerned you can close this bug.
i did some more testing using stock wine 0.9 rpm and the rpms from fedora.lowlatency.de and it turned 
out that the problems i've had were related to a specific .EXE (had to set sound to emulation in order not 
to get an unhandled exception).
Comment 12 Dave Jones 2005-11-10 14:01:20 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 13 Joe Christy 2005-11-15 14:59:17 EST
I still get crashes on one of my two FC4 machines, but not the other.
After building a fresh wine from today's CVS from winehq, the user environment
setup program wineprefixcreate crashes with the following backtrace.
Comment 14 Joe Christy 2005-11-15 15:03:55 EST
Created attachment 121086 [details]
WineDbg provided backtrace of wine page fault

This no longer locks up the machine.
Comment 15 Andreas Bierfert 2006-01-18 05:00:32 EST
Does this still happen with the current wine version from FE?
Comment 16 Dave Jones 2006-02-03 00:09:31 EST
This is a mass-update to all currently open kernel bugs.

A new kernel update has been released (Version: 2.6.15-1.1830_FC4)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO_REPORTER state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

Thank you.
Comment 17 John Thacker 2006-05-04 21:38:01 EDT
Closing per previous comment.

Note You need to log in before you can comment on or make changes to this bug.