Bug 169696 - crazy loadavg detected by top and nagios
crazy loadavg detected by top and nagios
Status: CLOSED DUPLICATE of bug 169962
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-01 09:21 EDT by John Ellson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 18:21:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2005-10-01 09:21:15 EDT
Description of problem:
I know my FX55 is quite fast, but this is crazy!

top - 09:17:38 up  1:00,  5 users,  load average: 350152.19, 318442.47,
651266.8Tasks: 114 total,   1 running, 113 sleeping,   0 stopped,   0 zombie
Cpu(s): 19.6% us, 17.3% sy, 18.2% ni,  8.0% id,  7.1% wa, 11.9% hi, 17.9% si
Mem:   1024592k total,   992044k used,    32548k free,    52792k buffers
Swap:  2048236k total,        0k used,  2048236k free,   541640k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
 4358 ellson    15   0  167m  19m  10m S 12.6  2.0   0:01.56 gnome-terminal
 4143 root      15   0  175m  28m 8284 S  5.0  2.9   0:39.52 X
 4344 ellson    15   0  379m  75m  23m S  0.3  7.5   0:43.09 firefox-bin
 6134 ellson    16   0  7300 1228  896 R  0.3  0.1   0:00.05 top


Version-Release number of selected component (if applicable):
kernel-2.6.13-1.1588_FC5

How reproducible:
?

Steps to Reproduce:
1.top
2.
3.
  
Actual results:
Load avgs bounce around all over the place: -667287.09, 493018.25, ...

Expected results:
Average in range 0 to +20 or so.  No -ve values.  Nothing above 100 or so.

Additional info:
Comment 1 John Ellson 2005-10-03 19:59:29 EDT
Seems to be fixed in kernel-2.6.13-1.1589_FC5
Comment 2 John Ellson 2005-10-05 11:00:57 EDT
Problem is back in kernel-2.6.13-1.1594_FC5

top - 11:01:55 up 8 min,  4 users,  load average: -451549.35, -2173.65,
-167270.Tasks: 110 total,   2 running, 108 sleeping,   0 stopped,   0 zombie
Cpu(s):  0.0% us,  0.0% sy,  0.0% ni,  0.0% id,  0.0% wa, 100.0% hi,  0.0% si
Mem:   1024592k total,   525728k used,   498864k free,    49224k buffers
Swap:  2048236k total,        0k used,  2048236k free,   245928k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
 3192 ellson    15   0  7296  980  720 R  2.0  0.1   0:00.01 top
    1 root      15   0  7060  680  556 S  0.0  0.1   0:00.56 init
Comment 3 Dave Jones 2005-10-05 18:21:58 EDT

*** This bug has been marked as a duplicate of 169962 ***

Note You need to log in before you can comment on or make changes to this bug.