Bug 169962 - CPU hotplug code is broken
Summary: CPU hotplug code is broken
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL: http://marc.theaimsgroup.com/?l=linux...
Whiteboard:
Keywords:
: 169696 169983 170408 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-05 21:20 UTC by Brian Gerst
Modified: 2015-01-04 22:22 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2005-10-19 16:52:38 UTC


Attachments (Terms of Use)
[PATCH] Fix hotplug cpu on x86_64 (2.69 KB, patch)
2005-10-07 04:19 UTC, Brian Gerst
no flags Details | Diff

Description Brian Gerst 2005-10-05 21:20:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Description of problem:
The current x86_64 CPU hotplug code has a serious bug in it where uninitialized per-cpu data is being used, causing strange values in /proc/stat and /proc/loadavg, and possibly more significant corruption.

Version-Release number of selected component (if applicable):
2.6.13-1.1594_FC5

How reproducible:
Always

Steps to Reproduce:
$ cat /proc/loadavg



Actual Results:  1520403.66 -986344.09 666845.94 1/68 23510

Expected Results:  Should be small numbers, and never negative.

Additional info:

Disable CONFIG_HOTPLUG_CPU until fixed.

Comment 1 Dave Jones 2005-10-05 22:22:18 UTC
*** Bug 169696 has been marked as a duplicate of this bug. ***

Comment 2 Dave Jones 2005-10-06 05:19:19 UTC
*** Bug 169983 has been marked as a duplicate of this bug. ***

Comment 3 Brian Gerst 2005-10-07 04:19:41 UTC
Created attachment 119699 [details]
[PATCH] Fix hotplug cpu on x86_64

Comment 4 Ignacio Vazquez-Abrams 2005-10-11 14:02:04 UTC
*** Bug 170408 has been marked as a duplicate of this bug. ***

Comment 5 Brian Gerst 2005-10-11 23:49:18 UTC
Fixed in kernel 2.6.14-rc4

Comment 6 Alexandre Oliva 2005-10-19 16:52:38 UTC
kernel-2.6.13-1.1601_FC5 has the fix.


Note You need to log in before you can comment on or make changes to this bug.