This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 169698 - no sound and mixer controls (snd_emu10k1) after kernel update 2.6.12 to 2.6.13
no sound and mixer controls (snd_emu10k1) after kernel update 2.6.12 to 2.6.13
Status: CLOSED DUPLICATE of bug 169152
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-01 09:54 EDT by Andreas M. Kirchwitz
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-02 17:17:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas M. Kirchwitz 2005-10-01 09:54:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050920

Description of problem:
After upgrading from kernel-2.6.12-1.1456_FC4 (official version for FC4)
to kernel-2.6.13-1.1526_FC4 (official successor), some mixer controls
like "Master" and "PCM" are missing from all mixer tools like
alsamixer or gnome-volume-control.

Furthermore, the sound output remains silent. My sound card is a
Creative Soundblaster Live. alsamixer identifies it as
"SBLive! Platinum 5.1 [SB0060]". My PC is a Dell Dimension XPS T600
(Pentium III at 600 MHz - yes, it's slow, but good enough for sound ;-)

I've never had such strange behaviour before. https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=168668
describes the same bug, but for FC5.
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=169152
mentions some backported emu10k1 fixes from kernel 2.6.14
which might be related somehow to the new problem.

To make sure that the problem is not related to weird mixer settings,
I deleted /etc/asound.state and did a "mkdir /etc/asound.state" which
effectively keeps the system from storing any mixer settings and
forces fresh default mixer settings after reboot. However, mixer
settings don't make any difference.

Version-Release number of selected component (if applicable):
kernel-2.6.13-1.1526_FC4

How reproducible:
Always

Steps to Reproduce:
1. Boot with kernel-2.6.13-1.1526_FC4
2. Run alsamixer (or any other mixer tool)
3. There's no "master" volume control (usually left of headphone settings)
4. Alternatively, run "system-config-soundcard" which complains about missing mixer controls

Actual Results:  The mixer controls "Master" and "PCM" (and maybe others, haven't
compared them one by one) are missing and no sound can be heard.

If I run "system-config-soundcard" (as root) to re-detect my sound
card, it detects the SB Live but when playing the test sound it
outputs these error messages:

amixer: Unable to find simple control 'Master',0
amixer: Unable to find simple control 'PCM',0
amixer: Unable to find simple control 'PCM-2',0
amixer: Unable to find simple control 'DRC Range',0


Expected Results:  Well, I expect to have all mixer controls and to hear sound. ;-)

Additional info:

lspci -vv
=========

00:10.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
        Subsystem: Creative Labs SBLive! Player 5.1
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 64 (500ns min, 5000ns max)
        Interrupt: pin A routed to IRQ 9
        Region 0: I/O ports at 1060 [size=32]
        Capabilities: <available only to root>

lsmod
=====
Module                  Size  Used by
autofs4                42309  2 
sunrpc                197509  1 
iptable_filter          3137  1 
ip_tables              19905  1 iptable_filter
vfat                   14017  1 
fat                    58461  1 vfat
dm_mod                 61917  0 
uhci_hcd               43345  0 
i2c_piix4               9169  0 
i2c_core               21697  1 i2c_piix4
emu10k1_gp              3905  0 
gameport               21321  2 emu10k1_gp
snd_emu10k1_synth      10049  0 
snd_emux_synth         51265  1 snd_emu10k1_synth
snd_seq_virmidi         6977  1 snd_emux_synth
snd_seq_midi_emul       6977  1 snd_emux_synth
snd_emu10k1           159717  2 snd_emu10k1_synth
snd_rawmidi            36321  2 snd_seq_virmidi,snd_emu10k1
snd_ac97_codec         80829  1 snd_emu10k1
snd_seq_dummy           3781  0 
snd_seq_oss            42945  0 
snd_seq_midi_event     10177  2 snd_seq_virmidi,snd_seq_oss
snd_seq                78033  8 snd_emux_synth,snd_seq_virmidi,snd_seq_midi_emul,snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          9165  7 snd_emu10k1_synth,snd_emux_synth,snd_emu10k1,snd_rawmidi,snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            53105  0 
snd_mixer_oss          18241  1 snd_pcm_oss
snd_pcm               112201  3 snd_emu10k1,snd_ac97_codec,snd_pcm_oss
snd_timer              42437  3 snd_emu10k1,snd_seq,snd_pcm
snd_page_alloc         10825  2 snd_emu10k1,snd_pcm
snd_util_mem            5057  2 snd_emux_synth,snd_emu10k1
snd_hwdep               9313  2 snd_emux_synth,snd_emu10k1
snd                    62021  15 snd_emux_synth,snd_seq_virmidi,snd_emu10k1,snd_rawmidi,snd_ac97_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep
soundcore              12449  1 snd
e100                   61249  0 
mii                     5569  1 e100
floppy                 71861  0 
ext3                  138568  9 
jbd                   111065  1 ext3
raid1                  29889  9
Comment 1 Dave Jones 2005-10-02 17:17:34 EDT

*** This bug has been marked as a duplicate of 169152 ***

Note You need to log in before you can comment on or make changes to this bug.