Bug 169152 - (FC4_EMU10K1) no sound (emu10k1) after kernel update
no sound (emu10k1) after kernel update
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 169698 169727 169745 (view as bug list)
Depends On:
Blocks: FCMETA_ALSA
  Show dependency treegraph
 
Reported: 2005-09-23 13:52 EDT by drago01
Modified: 2015-01-04 17:22 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-25 04:22:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description drago01 2005-09-23 13:52:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); de-DE; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc4 Firefox/1.0.6

Description of problem:
After updateing to the lastest testing kernel (using fc4) my sound stopped working.
The soundcard is detected ; the module is loaded but I hear no sound (it works fine with kernel-2.6.12-1.1456_FC4 and all earlier kernels)
I have no erros in dmesg or in /var/log/messages.
I have checked the mixer settings and confirmed that they are the same as in kernel-2.6.12-1.1456_FC4.

Any idea how to give more info or what can be causing this?


Version-Release number of selected component (if applicable):
kernel-2.6.13-1.1524_FC4

How reproducible:
Always

Steps to Reproduce:
1. boot with kernel-2.6.13-1.1524_FC4
2. try to play any sound
3. notice that you hear nothing
  

Actual Results:  no sound

Expected Results:  sound should play as it did with older kernels

Additional info:

I am using FC4 on x86_64.
lspic output:
-------------
00:00.0 Host bridge: nVidia Corporation nForce3 250Gb Host Bridge (rev a1)
00:01.0 ISA bridge: nVidia Corporation nForce3 250Gb LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation nForce 250Gb PCI System Management (rev a1)
00:02.0 USB Controller: nVidia Corporation CK8S USB Controller (rev a1)
00:02.1 USB Controller: nVidia Corporation CK8S USB Controller (rev a1)
00:02.2 USB Controller: nVidia Corporation nForce3 EHCI USB 2.0 Controller (rev a2)
00:05.0 Bridge: nVidia Corporation CK8S Ethernet Controller (rev a2)
00:08.0 IDE interface: nVidia Corporation CK8S Parallel ATA Controller (v2.5) (rev a2)
00:0a.0 IDE interface: nVidia Corporation CK8S Serial ATA Controller (v2.5) (rev a2)
00:0b.0 PCI bridge: nVidia Corporation nForce3 250Gb AGP Host to PCI Bridge (rev a2)
00:0e.0 PCI bridge: nVidia Corporation nForce3 250Gb PCI-to-PCI Bridge (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce 6600/GeForce 6600 GT] (rev a2)
02:09.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 0a)
02:09.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 0a)
02:0c.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 46)
02:0d.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)
Comment 1 Dave Jones 2005-09-23 18:20:50 EDT
I'm building a 1525 kernel right now, with some fixes to emu10k1 from 2.6.14rc.
Please give this a test when it appears at 
http://people.redhat.com/davej/kernels/Fedora/FC4/
Comment 2 drago01 2005-09-24 02:16:29 EDT
with this one sound works, but the 'Master' mixer has no effect (cannot controll
volume and mute the sound)
Comment 3 drago01 2005-09-24 02:24:02 EDT
the wave-* mixer does effekt the volume (I am using 5.1 sound)
Comment 4 drago01 2005-09-24 02:52:06 EDT
fixed this by playing with the mixer settings in alsamixer
Comment 5 Matthias Hensler 2005-09-25 13:58:28 EDT
Got some ugly sound problems with 2.6.13-1.1524_FC4 too, but on an Intel 8x0
chipset. Sound output is garbled and strange, might be a similar problem.

No problem with the 2.6.12 from FC4-base/updates and also no problem with recent
2.6.13 and 2.6.14-rcX from rawhide.

I will check this with 2.6.13-1.1525_FC4 now, and try to track it down. I will
open a seperate bugzilla entry if it is not related to this problem.
Comment 6 Matthias Hensler 2005-09-25 15:18:45 EDT
The following are experiences with Intel 810 sound, and are most likely not
related to this bug!

Well, I will add some unqualified and random notes. 2.6.13-1.152[45]_FC4 behaves
a bit "strange" on the sounddevice, which were not there in any of the previous
or rawhide kernels.

With I 2.6.13-1.152[45]_FC4 I had "garbled sound" (sound playing slowly or
having a lot of noice when playing with alsa), playing fine when using
OSS-output, and having no sound at all with both Alsa and OSS output. Playing
with alsamixer sometimes only brought a lot of white noise but not fixing the
problem.

I know this all is not very helpful, but difficult to reproduce here.

After recreating /etc/alsa/pcm/(dmix|dsnoop).conf from alsa-lib, removing
/etc/asound.state, unloading all alsa modules and starting from the scratch
everything works fine now.

This all might or might not related to this specific kernel, I cannot say. Since
the topic here is about the emu10k1, and no longer an issue for me, please do
not put too much weight into my bugreport.
Comment 7 Dave Jones 2005-09-25 16:14:35 EDT
Please, file a separate bug report for issues unrelated to emu10k1.
Comment 8 Damien 2005-09-27 09:29:35 EDT
I am unable to get any sound with any of the 2.6.13 fedora rawhide kernels. 
I've tried the 1525 kernel above without success.
My sound stopped working when I moved from FC4 to rawhide.

[root@localhost ~]# lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8377 [KT400/KT600 AGP] Host
Bridge00:01.0 PCI bridge: VIA Technologies, Inc. VT8235 PCI Bridge
00:05.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
00:0a.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
00:0a.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 07)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 80)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 80)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 80)
00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV100 QY [Radeon
7000/VE]


Is there any other information that may help get this fixed ?
Comment 9 Fedora Update System 2005-09-29 23:12:33 EDT
From User-Agent: XML-RPC

kernel-2.6.13-1.1526_FC4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 10 Christoph Wickert 2005-10-01 17:06:50 EDT
(In reply to comment #9)
> From User-Agent: XML-RPC
> 
> kernel-2.6.13-1.1526_FC4 has been pushed for FC4, which should resolve this
issue.  If these problems are still present in this version, then please make
note of it in this bug report.

I'd like to reopen the bug although I'm not the reporter.

After updating to the current kernel-2.6.13-1.1526_FC4 I've lost sound on my
machine (i386, K7S5A Board, Soundblaster Live!).

Both alsamixer and gnome-volume-control have lost most of their sliders, only
front right, front left and left rear are left when I boot the new kernel, no
master, no line in, no whatever. system-config-soundcard is unable to play the
test sound. The old kernels work fine, I never had problems before with this
soundcard, this is the first time _ever_.

00:00.0 Host bridge: Silicon Integrated Systems [SiS] 735 Host (rev 01)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] Virtual PCI-to-PCI bridge (AGP)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS85C503/5513 (LPC Bridge)
00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
00:02.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 07)
00:02.3 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 07)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev d0)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] Sound
Controller (rev a0)
00:09.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
00:0b.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 61)
00:0b.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 61)
00:0b.2 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 63)
00:0b.3 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller
(rev 46)
00:0d.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
00:0d.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 07)
00:0f.0 Network controller: AVM Audiovisuelles MKTG & Computer System GmbH A1
ISDN [Fritz] (rev 02)
00:11.0 Multimedia video controller: Brooktree Corporation Bt848 Video Capture
(rev 12)
01:00.0 VGA compatible controller: nVidia Corporation NV5 [RIVA TNT2/TNT2 Pro]
(rev 15)
Comment 11 stephen 2005-10-02 01:03:20 EDT
SB Live 5.1 Gamer, front speakers not working on mine since installing the
x.x.13.x kernel on FC4.  Using 4.1 speakers, analog, dual cable setup.

I installed 2.6.13-1.1526_FC4 yesterday.  Sound worked fine on the prior 3-4 or
so kernel releases.  The only sound option that remained on the Playback tab of
Volume Control was a 3 bar EMU10K1 PCM controller, which I have never seen
before.  I added Wave Surround in to get the rear speakers working.

There is no longer an option for Master and if I check on Wave, etc., it wont
add it to the sound panel.  Plain PCM option is also missing.

Stephen
Comment 12 drago01 2005-10-02 02:14:27 EDT
Reopened because it seems still to be broken for many users.
Comment 13 Dave Jones 2005-10-02 17:17:52 EDT
*** Bug 169698 has been marked as a duplicate of this bug. ***
Comment 14 Dave Jones 2005-10-02 17:39:07 EDT
*** Bug 169727 has been marked as a duplicate of this bug. ***
Comment 15 Dave Jones 2005-10-02 18:03:27 EDT
*** Bug 169745 has been marked as a duplicate of this bug. ***
Comment 16 Dave Jones 2005-10-02 18:35:32 EDT
Can I get the output of 
lspci -x -s `lspci -x | grep EMU10k1|awk '{print $1}'`

from some of these please ?
Comment 17 Christoph Wickert 2005-10-02 18:49:48 EDT
Mine is:

lspci -x -s `lspci -x | grep EMU10k1|awk '{print $1}'`
00:0d.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
00: 02 11 02 00 05 01 90 02 07 00 01 04 00 40 80 00
10: 01 c0 00 00 00 00 00 00 00 00 00 00 00 00 00 00
20: 00 00 00 00 00 00 00 00 00 00 00 00 02 11 61 80
30: 00 00 00 00 dc 00 00 00 00 00 00 00 0b 01 02 14
Comment 18 Dave Jones 2005-10-02 20:46:30 EDT
Can you try the 1527 test kernel at http://people.redhat.com/davej/kernels/Fedora/FC4/
Comment 19 Christoph Wickert 2005-10-02 21:04:38 EDT
Works4Me, sound is back again.
Comment 20 Dimitris 2005-10-03 00:51:47 EDT
00:13.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
00: 02 11 02 00 05 00 90 02 07 00 01 04 00 30 80 00
10: 01 88 00 00 00 00 00 00 00 00 00 00 00 00 00 00
20: 00 00 00 00 00 00 00 00 00 00 00 00 02 11 61 80
30: 00 00 00 00 dc 00 00 00 00 00 00 00 0a 01 02 14
Comment 21 Brad Wade 2005-10-03 15:15:55 EDT
Works for me, too, with 1527 test kernel (was broken in
kernel-2.6.13-1.1526_FC4).  Master volume control is now visible again in
alsamixer.  Thanks!
Comment 22 Dimitris 2005-10-05 04:50:10 EDT
Works with 2.6.13-1.1528_FC4.
Comment 23 David 2005-10-06 16:07:15 EDT
This also occurs with the Creative Labs SB Audigy LS using the ca0106 module in
the kernel-2.6.13-1.152[678]_FC4.
Comment 24 Ted 2005-10-08 10:00:27 EDT
Still broken with 2.6.13-1.1528_FC4.  /dev/dsp is not being created on bootup,
all the mixer stuff shows up in alsamixer now though.

00:0a.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
00: 02 11 02 00 05 00 90 02 07 00 01 04 00 40 80 00
10: 01 1c 00 00 00 00 00 00 00 00 00 00 00 00 00 00
20: 00 00 00 00 00 00 00 00 00 00 00 00 02 11 61 80
30: 00 00 00 00 dc 00 00 00 00 00 00 00 09 01 02 14
Comment 25 Thomas Antony 2005-10-09 17:51:27 EDT
I also have this bug with 1526. I didn't try any kernel > 1526

01:07.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
00: 02 11 02 00 05 00 90 02 07 00 01 04 00 20 80 00
10: 01 ac 00 00 00 00 00 00 00 00 00 00 00 00 00 00
20: 00 00 00 00 00 00 00 00 00 00 00 00 02 11 61 80
30: 00 00 00 00 dc 00 00 00 00 00 00 00 03 01 02 14
Comment 26 Luis A. Florit 2005-10-13 18:20:40 EDT
Same here: no sound with 1526 and 1528, FC4 fully updated.
Comment 27 Dimitris 2005-10-13 19:26:09 EDT
I'd like to point out that once i updated from 1526 to 1528 i still couldn't get
any sound. Fortunately, i checked the alsamixer settings and found out that the
upgrade had muted PCM and Master. Once i corrected those, sound worked fine.
Comment 28 Luis A. Florit 2005-10-17 10:17:30 EDT
(In reply to comment #27)
> I'd like to point out that once i updated from 1526 to 1528 i still couldn't get
> any sound. Fortunately, i checked the alsamixer settings and found out that the
> upgrade had muted PCM and Master. Once i corrected those, sound worked fine.

Not for me. PCM and Master are present and I can move them normally.
Just no sound...

L.
Comment 29 Marshall Lewis 2005-10-18 18:38:31 EDT
I tried the latest kernel under
http://people.redhat.com/davej/kernels/Fedora/FC4/
(kernel-2.6.13-1.1531_FC4.x86_64.rpm to be precise) and I still have no sound. 
I didn't find this bug early enough to try the 1528 build.  I've checked my
mixer settings and nothing is muted.
Comment 30 Andreas Bierfert 2005-10-19 16:47:37 EDT
Works here with 1531...

[10:49 PM][awjb@alkaid ~]$ lspci -x -s `lspci -x | grep EMU10k1|awk '{print $1}'`
00:0e.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
00: 02 11 02 00 05 00 90 02 07 00 01 04 00 20 80 00
10: 01 a8 00 00 00 00 00 00 00 00 00 00 00 00 00 00
20: 00 00 00 00 00 00 00 00 00 00 00 00 02 11 61 80
30: 00 00 00 00 dc 00 00 00 00 00 00 00 ff 01 02 14

[10:49 PM][awjb@alkaid ~]$ uname -a                                            
Linux alkaid 2.6.13-1.1531_FC4 #1 Sun Oct 16 23:10:35 EDT 2005 i686 athlon i386
GNU/Linux
Comment 31 Marshall Lewis 2005-10-21 19:43:22 EDT
Found out my problem (after upgrading to 1532).  The upgrade hadn't muted
anything, but for some reason had turned off the output jack. Found it in
alsamixer - "Audigy Analog/Digital Output Jack" - turning it on has fixed my
sound problem.
Comment 32 Nicolas GIF 2005-10-22 03:06:02 EDT
Now it works for me on kernel 1532.
Comment 33 Thomas Antony 2005-10-22 04:16:43 EDT
kernel 1532 fixed it here to, but sound recording is still not working as it
should, but this has never worked with any FC4 kernel. I hoped this kernel
release would fix this also.
Comment 34 Andreas M. Kirchwitz 2005-10-23 08:57:44 EDT
Thanks a lot, it works again. Great!

However, I still have to zero "Wave Center" and "Wave LFE", otherwise
the "PCM" volume doesn't do much useful, but that seems to be a general
Alsa issue and can be easily worked around.

Thanks again to make sound playback work! (Cannot say much about
recording, don't have a microphone to test it.)
Comment 35 Dave Jones 2005-10-25 04:22:44 EDT
The ALSA drivers have so many quirks (enable slider x to make slider y work etc)
that it's almost impossible to keep track of them all.  If things don't "just
work" I suggest bringing it up upstream in their bug tracker at
http://www.alsa-project.org

Note You need to log in before you can comment on or make changes to this bug.