Bug 169729 - Kernel update makes snd-atiixp-modem & slmodemd fail
Kernel update makes snd-atiixp-modem & slmodemd fail
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: alsa-utils (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
: 175220 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-02 06:38 EDT by Patrick
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-13 10:55:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/proc/asound/cards (220 bytes, text/plain)
2005-11-25 08:47 EST, Patrick
no flags Details
/proc/asound/cards from the right box this time. Sorry (222 bytes, text/plain)
2005-11-25 09:56 EST, Patrick
no flags Details
Output of strace -o output.txt aplay -D modem:1 /usr/share/sounds/phone.wav as root (7.07 KB, text/plain)
2005-12-06 06:03 EST, Patrick
no flags Details
Output of strace -o output.txt aplay -D modem:1 /usr/share/sounds/phone.wav as a normal user (7.07 KB, text/plain)
2005-12-06 06:04 EST, Patrick
no flags Details
Output of strace -o output.txt aplay -D modem:1 /usr/share/sounds/phone.wav as root with dmix.conf restored (7.46 KB, text/plain)
2005-12-06 10:03 EST, Patrick
no flags Details

  None (edit)
Description Patrick 2005-10-02 06:38:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
I use slmodemd on top of the snd-atiixp-modem module to drive the softmodem
on my Acer laptop. On kernel 2.6.12-1.1447 it works using modem:1,0 as
the device. On kernel 2.6.13-1.1526 it fails. After some more investigation I found out that it is possible to use hw:0 or hw:1 as device on the 1526 kernel. This line is used to figure out which device to use: aplay -l  2>&1 | sed -ne '/ Modem/s/^card \([0-9]\).*, device \([0-9]\).*/modem:\1,\2/p'

Here is the error output on kernel 2.6.13-1.1526:
[root@speedy ~]# slmodemd --alsa -c NETHERLANDS modem:1,0
error: mixer setup: Off-hook switch not found for card hw:1
ALSA lib conf.c:1578:(snd_config_load1) _toplevel_:51:23:No such file or directory
ALSA lib conf.c:2823:(snd_config_hook_load) /etc/alsa/cards/aliases.conf may be old or corrupted: consider to remove or fix it
ALSA lib conf.c:2686:(snd_config_hooks_call) function snd_config_hook_load returned error: No such file or directory
ALSA lib pcm.c:1959:(snd_pcm_open_conf) Invalid type for PCM modem:1,0 definition (id: modem, value: cards.pcm.modem)
error: alsa setup: cannot open playback device 'modem:1,0': Invalid argument
error: cannot setup device `modem:1,0'

Version-Release number of selected component (if applicable):
kernel-2.6.13-1.1526

How reproducible:
Always

Steps to Reproduce:
1. boot laptop with kernel 2.6.13-1.1526
2. wait till the slmodemd service starts
3. see if fail on 
  

Actual Results:  slmodemd daemon startup fails

Expected Results:  slmodemd should start up without error

Additional info:
Comment 1 Patrick 2005-10-02 08:40:38 EDT
My apologies I'm daft. The issue was not caused by the kernel upgrade but by a
problem with /etc/alsa/cards/aliases.conf. I just remembered that when I was
running 2.6.12-1.1447 I removed this aliases.conf file and then slmodemd worked.
Perhaps this is an alsa bug and needs reassigning so here is the error output if
the aliases.conf file is present in /etc/alsa/cards (running 2.6.12-1.1447):
[root@speedy]# slmodemd -a -c NETHERLANDS modem:1,0
error: mixer setup: Off-hook switch not found for card hw:1
ALSA lib conf.c:1578:(snd_config_load1) _toplevel_:51:23:No such file or directory
ALSA lib conf.c:2823:(snd_config_hook_load) /etc/alsa/cards/aliases.conf may be
old or corrupted: consider to remove or fix it
ALSA lib conf.c:2686:(snd_config_hooks_call) function snd_config_hook_load
returned error: No such file or directory
ALSA lib pcm.c:1959:(snd_pcm_open_conf) Invalid type for PCM modem:1,0
definition (id: modem, value: cards.pcm.modem)
error: alsa setup: cannot open playback device 'modem:1,0': Invalid argument
error: cannot setup device `modem:1,0'

Output when aliases.conf file is removed:
[root@speedy]# slmodemd -a -c NETHERLANDS modem:1,0
error: mixer setup: Off-hook switch not found for card hw:1
ALSA lib conf.c:2827:(snd_config_hook_load) cannot access file
/etc/alsa/cards/aliases.conf
SmartLink Soft Modem: version 2.9.9e-pre1 Oct  2 2005 13:07:33
symbolic link `/dev/ttySL0' -> `/dev/pts/2' created.
modem `modem:1,0' created. TTY is `/dev/pts/2'
Modem device: `/dev/ttySL0'

Alsa versions:
alsa-lib-1.0.9rf-2.FC4
alsa-lib-devel-1.0.9rf-2.FC4
alsa-utils-1.0.9rf-2.FC4
alsa-lib-1.0.9rf-2.FC4
(prolly 32bit and 64bit rpms)
Comment 2 Martin Stransky 2005-10-05 06:05:55 EDT
Can you use your modem as a regular user (no root)?
Comment 3 Patrick 2005-10-05 07:29:13 EDT
If the slmodemd service starts (as root from /etc/rc.d/init.d) I can use the
modem fine as a non-root user. Output when I try to dial out as a normal user
(no phoneline is attached):

Oct  5 13:24:19 speedy kernel: ACPI: PCI Interrupt 0000:00:14.6[B] -> GSI 17
(level, low) -> IRQ 209
Oct  5 13:24:34 speedy ifup-ppp: pppd started for KPN on /dev/modem at 115200
Oct  5 13:24:34 speedy kernel: CSLIP: code copyright 1989 Regents of the
University of California
Oct  5 13:24:34 speedy kernel: PPP generic driver version 2.4.2
Oct  5 13:24:34 speedy pppd[3024]: pppd 2.4.2 started by root, uid 0
Oct  5 13:24:35 speedy wvdial[3044]: WvDial: Internet dialer version 1.54.0
Oct  5 13:24:35 speedy wvdial[3044]: Initializing modem.
Oct  5 13:24:35 speedy wvdial[3044]: Sending: ATZ
Oct  5 13:24:35 speedy wvdial[3044]: ATZ
Oct  5 13:24:35 speedy wvdial[3044]: OK
Oct  5 13:24:35 speedy wvdial[3044]: Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Oct  5 13:24:36 speedy wvdial[3044]: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Oct  5 13:24:36 speedy wvdial[3044]: OK
Oct  5 13:24:36 speedy wvdial[3044]: Sending: ATM1L3
Oct  5 13:24:36 speedy wvdial[3044]: ATM1L3
Oct  5 13:24:36 speedy wvdial[3044]: OK
Oct  5 13:24:36 speedy wvdial[3044]: Modem initialized.
Oct  5 13:24:36 speedy wvdial[3044]: Sending: ATDT0676012321
Oct  5 13:24:36 speedy wvdial[3044]: Waiting for carrier.
Oct  5 13:24:36 speedy wvdial[3044]: ATDT0676012321
Oct  5 13:24:40 speedy wvdial[3044]: NO DIALTONE
Oct  5 13:24:40 speedy wvdial[3044]: No dial tone.
Oct  5 13:24:40 speedy wvdial[3044]: Disconnecting at Wed Oct  5 13:24:40 2005
Oct  5 13:24:43 speedy pppd[3024]: Connect script failed
Oct  5 13:24:44 speedy pppd[3024]: Exit.

I upgraded to kernel 2.6.13-1.1526. Rebuilt slmodemd rpm with this kernel active
(in case it could make a difference). 

With aliases.conf *not* in /etc/alsa/cards the slmodemd service starts ok as
root. With aliases.conf put back in /etc/alsa/cards and as a non-root user it
does *not* work. Output:
[patrick@speedy ~]$ /usr/sbin/slmodemd --alsa --country NETHERLANDS modem:1,0
error: mixer setup: attach hw:1 error: No such file or directory
ALSA lib conf.c:1578:(snd_config_load1) _toplevel_:51:23:No such file or directory
ALSA lib conf.c:2823:(snd_config_hook_load) /etc/alsa/cards/aliases.conf may be
old or corrupted: consider to remove or fix it
ALSA lib conf.c:2686:(snd_config_hooks_call) function snd_config_hook_load
returned error: No such file or directory
ALSA lib pcm.c:1959:(snd_pcm_open_conf) Invalid type for PCM modem:1,0
definition (id: modem, value: cards.pcm.modem)
error: alsa setup: cannot open playback device 'modem:1,0': Invalid argument
error: cannot setup device `modem:1,0'

With aliases.conf removed and trying to start slmodemd as a non-root user I get
some permission errors::
[patrick@speedy ~]$ /usr/sbin/slmodemd --alsa --country NETHERLANDS modem:1,0
SmartLink Soft Modem: version 2.9.9e-pre1 Oct  5 2005 02:54:37
error: cannot chown '/dev/pts/3' to ':uucp': Operation not permitted
error: cannot create symbolink link `/dev/ttySL0' -> `/dev/pts/3': Permission denied
modem `modem:1,0' created. TTY is `/dev/pts/3'
error: mlockall: Cannot allocate memory
error: sched_setscheduler: Operation not permitted
Modem device: `/dev/pts/3'

If I try to dial out as a normal user I get:
Oct  5 13:29:46 speedy ifup-ppp: pppd started for KPN on /dev/modem at 115200
Oct  5 13:29:46 speedy pppd[3207]: unrecognized option '/dev/modem'

As root the output of aplay -l  2>&1 | sed -ne '/ Modem/s/^card \([0-9]\).*,
device \([0-9]\).*/modem:\1,\2/p' is: modem:1,0

As non-root the output of the same command is: nothing.

As non-root the output of aplay -l is: 
[patrick@speedy ~]$ aplay -l
aplay: device_list:218: no soundcards found...

Alsa related stuff from /etc/modprobe.conf:
alias char-major-116 snd
alias snd-card-0 snd-card-0
options snd-atiixp index=0
remove snd-atiixp { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-atiixp
# OSS/Free portion
alias char-major-14 soundcore
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

You can find the rpm at http://www.xs4all.nl/~pjl/slmodemd/ in case you want to
try it out yourself. Please let me know if you need more information. Thanks for
looking into it.
Comment 4 Martin Stransky 2005-10-05 07:58:43 EDT
I think it's a dupe of bug 169163, comment #5. You can check it...
Comment 5 Warren Togami 2005-10-05 08:14:57 EDT
Don't you mean Bug #169732?
Comment 6 Martin Stransky 2005-10-05 08:18:51 EDT
No, I mean bug 169163.
Comment 7 Patrick 2005-10-05 20:57:09 EDT
I removed the 2 lines from /etc/asound.conf and replaced them with the two lines
from bug 169163, comment #5. Rebooted and I still get the same error. Manually
starting slmodemd --alsa --country NETHERLANDS modem:1,0 also fails with the
same error. So those two replacing lines do not fix my problem.
Comment 8 Martin Stransky 2005-10-06 03:28:02 EDT
Could you check "slmodemd --alsa --country NETHERLANDS hw:1,0"?
Comment 9 Patrick 2005-10-10 18:38:12 EDT
That works fine:

[root@speedy ~]# slmodemd --alsa --country NETHERLANDS hw:1,0
SmartLink Soft Modem: version 2.9.9e-pre1 Oct  5 2005 02:54:37
symbolic link `/dev/ttySL0' -> `/dev/pts/2' created.
modem `hw:1,0' created. TTY is `/dev/pts/2'
Modem device: `/dev/ttySL0'

Some variations work fine too:

[root@speedy ~]# slmodemd --alsa --country NETHERLANDS hw:0
error: mixer setup: Off-hook switch not found for card hw:0
SmartLink Soft Modem: version 2.9.9e-pre1 Oct  5 2005 02:54:37
symbolic link `/dev/ttySL0' -> `/dev/pts/2' created.
modem `hw:0' created. TTY is `/dev/pts/2'
Modem device: `/dev/ttySL0'

[root@speedy ~]# slmodemd --alsa --country NETHERLANDS hw:1
SmartLink Soft Modem: version 2.9.9e-pre1 Oct  5 2005 02:54:37
symbolic link `/dev/ttySL0' -> `/dev/pts/2' created.
modem `hw:1' created. TTY is `/dev/pts/2'
Modem device: `/dev/ttySL0'

The only one that does not work:

[root@speedy ~]# slmodemd --alsa --country NETHERLANDS hw:0,1
error: mixer setup: Off-hook switch not found for card hw:0
error: alsa setup: cannot open playback device 'hw:0,1': No such file or directory
error: cannot setup device `hw:0,1'
Comment 10 Patrick 2005-10-10 18:45:09 EDT
Sorry forgot to mention: this is with the two new lines replacing the 2 lines in
/etc/asound.conf as mentioned in comment #7. If I put the two original lines
back in /etc/asound.conf, reboot and try your suggestion I get:

This works fine:

[root@speedy ~]# slmodemd --alsa --country NETHERLANDS hw:1,0
SmartLink Soft Modem: version 2.9.9e-pre1 Oct  5 2005 02:54:37
symbolic link `/dev/ttySL0' -> `/dev/pts/1' created.
modem `hw:1,0' created. TTY is `/dev/pts/1'
Modem device: `/dev/ttySL0'

Some variations work fine too:

[root@speedy ~]# slmodemd --alsa --country NETHERLANDS hw:0
error: mixer setup: Off-hook switch not found for card hw:0
SmartLink Soft Modem: version 2.9.9e-pre1 Oct  5 2005 02:54:37
symbolic link `/dev/ttySL0' -> `/dev/pts/1' created.
modem `hw:0' created. TTY is `/dev/pts/1'
Modem device: `/dev/ttySL0'

[root@speedy ~]# slmodemd --alsa --country NETHERLANDS hw:1
SmartLink Soft Modem: version 2.9.9e-pre1 Oct  5 2005 02:54:37
symbolic link `/dev/ttySL0' -> `/dev/pts/1' created.
modem `hw:1' created. TTY is `/dev/pts/1'
Modem device: `/dev/ttySL0'

The only one that does not work again:

[root@speedy ~]# slmodemd --alsa --country NETHERLANDS hw:0,1
error: mixer setup: Off-hook switch not found for card hw:0
error: alsa setup: cannot open playback device 'hw:0,1': No such file or directory
error: cannot setup device `hw:0,1'
Comment 11 Martin Stransky 2005-10-11 06:44:12 EDT
Thanks, it looks like a problem with the modem alias (it's alias for the HW device).
Comment 12 Martin Stransky 2005-11-25 08:39:18 EST
Could you attach the file /proc/asound/cards?
Comment 13 Patrick 2005-11-25 08:47:35 EST
Created attachment 121487 [details]
/proc/asound/cards
Comment 14 Martin Stransky 2005-11-25 08:59:58 EST
Hm, I don't see any modem...are you sure you have the proper module loaded?
Comment 15 Patrick 2005-11-25 09:56:48 EST
Created attachment 121490 [details]
/proc/asound/cards from the right box this time. Sorry
Comment 16 Martin Stransky 2005-11-25 10:04:41 EST
Could you please check this one? 

$aplay -D modem:1 /usr/share/sounds/phone.wav
Comment 17 Martin Stransky 2005-11-25 10:07:01 EST
Do you have the /etc/alsa/cards/ATIIXP-MODEM.conf file?
Comment 18 Patrick 2005-11-27 09:55:12 EST
(In reply to comment #17)
> Do you have the /etc/alsa/cards/ATIIXP-MODEM.conf file?

Yup. $cat /etc/alsa/cards/ATIIXP-MODEM.conf

#
# Configuration for the ATI IXP 150/200/250 modem controllers
#

<confdir:pcm/modem.conf>

ATIIXP-MODEM.pcm.modem.0 {
        @args [ CARD ]
        @args.CARD {
                type string
        }
        type route
        slave.pcm {
                type hw
                card $CARD
                device 0
        }
        slave.channels 2
        slave.format S16_LE
        ttable.0.1 1
        ttable.1.0 0
}

Comment 19 Patrick 2005-11-27 09:58:14 EST
(In reply to comment #16)
> Could you please check this one? 
> 
> $aplay -D modem:1 /usr/share/sounds/phone.wav

#lsmod | grep atiixp

snd_atiixp_modem       23045  0
snd_atiixp             28641  0
snd_ac97_codec        100741  2 snd_atiixp_modem,snd_atiixp
snd_pcm               128589  4
snd_atiixp_modem,snd_atiixp,snd_ac97_codec,snd_pcm_oss
snd                    73921  10
snd_atiixp_modem,snd_atiixp,snd_ac97_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
snd_page_alloc         12753  3 snd_atiixp_modem,snd_atiixp,snd_pcm

[ as a normal user ]
$aplay -D modem:1 /usr/share/sounds/phone.wav
ALSA lib conf.c:1578:(snd_config_load1) _toplevel_:51:23:No such file or directory
ALSA lib conf.c:2823:(snd_config_hook_load) /etc/alsa/cards/aliases.conf may be
old or corrupted: consider to remove or fix it
ALSA lib conf.c:2686:(snd_config_hooks_call) function snd_config_hook_load
returned error: No such file or directory
ALSA lib pcm.c:1959:(snd_pcm_open_conf) Invalid type for PCM modem:1 definition
(id: modem, value: cards.pcm.modem)
aplay: main:533: audio open error: Invalid argument

[ as root ]
ALSA lib conf.c:1578:(snd_config_load1) _toplevel_:51:23:No such file or directory
ALSA lib conf.c:2823:(snd_config_hook_load) /etc/alsa/cards/aliases.conf may be
old or corrupted: consider to remove or fix it
ALSA lib conf.c:2686:(snd_config_hooks_call) function snd_config_hook_load
returned error: No such file or directory
ALSA lib pcm.c:1959:(snd_pcm_open_conf) Invalid type for PCM modem:1 definition
(id: modem, value: cards.pcm.modem)
aplay: main:533: audio open error: Invalid argument

All done while running 2.6.13-1.1526_FC4


Comment 20 Martin Stransky 2005-11-28 04:11:05 EST
Which files do you have in /etc/alsa and /etc/alsa/pcm ?
Comment 21 Martin Stransky 2005-11-28 04:19:17 EST
Could you please check these ones?

aplay -D cards.ATIIXP-MODEM.pcm.modem.0:0 /usr/share/sounds/phone.wav
aplay -D cards.ATIIXP-MODEM.pcm.modem.0:1 /usr/share/sounds/phone.wav
aplay -D cards.ATIIXP-MODEM.pcm.modem.0 /usr/share/sounds/phone.wav
Comment 22 Patrick 2005-11-28 05:11:39 EST
(In reply to comment #20)
> Which files do you have in /etc/alsa and /etc/alsa/pcm ?

[root@speedy ~]# ll /etc/alsa
total 44
-rw-r--r--  1 root root  421 Jun 16 16:57 ainit.conf
-rw-r--r--  1 root root 7467 Jun 16 16:59 alsa.conf
drwxr-xr-x  3 root root 4096 Oct 30 19:47 cards
drwxr-xr-x  2 root root 4096 Nov 28 11:07 pcm
-rw-r--r--  1 root root 3205 Jun 16 16:57 sndo-mixer.alisp

[root@speedy ~]# ll /etc/alsa/cards
total 396
-rw-r--r--  1 root root  679 Jun 16 16:57 AACI.conf
-rw-r--r--  1 root root  687 Jun 16 16:57 aliases.alisp
-rw-r--r--  1 root root 1186 Jun 16 16:57 aliases.conf
-rw-r--r--  1 root root 2498 Jun 16 16:57 ATIIXP.conf
-rw-r--r--  1 root root  298 Jun 16 16:57 ATIIXP-MODEM.conf
-rw-r--r--  1 root root 2213 Jun 16 16:57 ATIIXP-SPDMA.conf
-rw-r--r--  1 root root  447 Jun 16 16:57 AU8810.conf
-rw-r--r--  1 root root  169 Jun 16 16:57 AU8820.conf
-rw-r--r--  1 root root  530 Jun 16 16:57 AU8830.conf
-rw-r--r--  1 root root 5102 Jun 16 16:57 Audigy2.conf
-rw-r--r--  1 root root 3738 Jun 16 16:57 Audigy.conf
-rw-r--r--  1 root root 1655 Jun 16 16:57 Aureon51.conf
-rw-r--r--  1 root root 1785 Jun 16 16:57 Aureon71.conf
-rw-r--r--  1 root root 3292 Jun 16 16:57 CA0106.conf
-rw-r--r--  1 root root 1921 Jun 16 16:57 CMI8338.conf
-rw-r--r--  1 root root 1794 Jun 16 16:57 CMI8338-SWIEC.conf
-rw-r--r--  1 root root 1873 Jun 16 16:57 CMI8738-MC6.conf
-rw-r--r--  1 root root 2301 Jun 16 16:57 CMI8738-MC8.conf
-rw-r--r--  1 root root 2721 Jun 16 16:57 CS46xx.conf
-rw-r--r--  1 root root 3789 Jun 16 16:57 EMU10K1.conf
-rw-r--r--  1 root root 2521 Jun 16 16:57 EMU10K1X.conf
-rw-r--r--  1 root root 1359 Jun 16 16:57 ENS1370.conf
-rw-r--r--  1 root root 1827 Jun 16 16:57 ENS1371.conf
-rw-r--r--  1 root root  162 Jun 16 16:57 ES1968.conf
-rw-r--r--  1 root root 1218 Jun 16 16:57 FM801.conf
-rw-r--r--  1 root root  794 Jun 16 16:57 GUS.conf
-rw-r--r--  1 root root 1844 Jun 16 16:57 HDA-Intel.conf
-rw-r--r--  1 root root 1536 Jun 16 16:57 ICE1712.conf
-rw-r--r--  1 root root 2118 Jun 16 16:57 ICE1724.conf
-rw-r--r--  1 root root 2863 Jun 16 16:57 ICH4.conf
-rw-r--r--  1 root root 3042 Jun 16 16:57 ICH.conf
-rw-r--r--  1 root root  187 Jun 16 16:57 ICH-MODEM.conf
-rw-r--r--  1 root root  164 Jun 16 16:57 Maestro3.conf
-rw-r--r--  1 root root 3070 Jun 16 16:57 NFORCE.conf
-rw-r--r--  1 root root  592 Jun 16 16:57 PC-Speaker.conf
-rw-r--r--  1 root root  713 Jun 16 16:57 PMacToonie.conf
-rw-r--r--  1 root root  803 Jun 16 16:57 RME9636.conf
-rw-r--r--  1 root root  803 Jun 16 16:57 RME9652.conf
drwxr-xr-x  2 root root 4096 Oct 13 19:37 SI7018
-rw-r--r--  1 root root 2210 Jun 16 16:57 SI7018.conf
-rw-r--r--  1 root root 1754 Jun 16 16:57 TRID4DWAVENX.conf
-rw-r--r--  1 root root 1259 Jun 16 16:57 VIA686A.conf
-rw-r--r--  1 root root 2866 Jun 16 16:57 VIA8233A.conf
-rw-r--r--  1 root root 2799 Jun 16 16:57 VIA8233.conf
-rw-r--r--  1 root root 2631 Jun 16 16:57 VIA8237.conf
-rw-r--r--  1 root root  639 Jun 16 16:57 VX222.conf
-rw-r--r--  1 root root 1289 Jun 16 16:57 VXPocket440.conf
-rw-r--r--  1 root root  648 Jun 16 16:57 VXPocket.conf
-rw-r--r--  1 root root 1367 Jun 16 16:57 YMF744.conf

[root@speedy ~]# ll /etc/alsa/pcm
total 136
-rw-r--r--  1 root root     634 Jun 16 16:57 center_lfe.conf
-rw-r--r--  1 root root     507 Jun 16 16:57 default.conf
-rw-r--r--  1 root patrick 1127 Nov 28 11:07 dmix.conf
-rw-r--r--  1 root patrick    0 Nov 28 11:07 dmix.conf.lock
-rw-r--r--  1 root root    1101 Jun 16 16:57 dmix.template
-rw-r--r--  1 root patrick 1118 Nov 28 11:07 dsnoop.conf
-rw-r--r--  1 root patrick    0 Nov 28 11:07 dsnoop.conf.lock
-rw-r--r--  1 root root    1093 Jun 16 16:57 dsnoop.template
-rw-r--r--  1 root root     596 Jun 16 16:57 front.conf
-rw-r--r--  1 root root    1030 Jun 16 16:57 iec958.conf
-rw-r--r--  1 root root     573 Jun 16 16:57 modem.conf
-rw-r--r--  1 root root     589 Jun 16 16:57 rear.conf
-rw-r--r--  1 root root     589 Jun 16 16:57 side.conf
-rw-r--r--  1 root root     749 Jun 16 16:57 surround40.conf
-rw-r--r--  1 root root     893 Jun 16 16:57 surround41.conf
-rw-r--r--  1 root root     896 Jun 16 16:57 surround50.conf
-rw-r--r--  1 root root     783 Jun 16 16:57 surround51.conf
-rw-r--r--  1 root root     828 Jun 16 16:57 surround71.conf
Comment 23 Patrick 2005-11-28 05:23:08 EST
(In reply to comment #21)
> Could you please check these ones?
> 
> aplay -D cards.ATIIXP-MODEM.pcm.modem.0:0 /usr/share/sounds/phone.wav
> aplay -D cards.ATIIXP-MODEM.pcm.modem.0:1 /usr/share/sounds/phone.wav
> aplay -D cards.ATIIXP-MODEM.pcm.modem.0 /usr/share/sounds/phone.wav

aplay -D cards.ATIIXP-MODEM.pcm.modem.0:0 /usr/share/sounds/phone.wav
Playing WAVE '/usr/share/sounds/phone.wav' : Signed 16 bit Little Endian, Rate
44100 Hz, Stereo
(I hear the ringing tone fine so this one works)

aplay -D cards.ATIIXP-MODEM.pcm.modem.0:0 /usr/share/sounds/phone.wav
Playing WAVE '/usr/share/sounds/phone.wav' : Signed 16 bit Little Endian, Rate
44100 Hz, Stereo
Warning: rate is not accurate (requested = 44100Hz, got = 16000 Hz)
         please try the plug plugin (-Dplug:cards.ATIIXP-MODEM.pcm.modem.0:1)
(don't hear anything but I try the suggestion)

aplay -Dplug:cards.ATIIXP-MODEM.pcm.modem.0:0 /usr/share/sounds/phone.wav
Playing WAVE '/usr/share/sounds/phone.wav' : Signed 16 bit Little Endian, Rate
44100 Hz, Stereo
(don't hear anything)

aplay -D cards.ATIIXP-MODEM.pcm.modem.0 /usr/share/sounds/phone.wav
ALSA lib pcm_hw.c:1345:(_snd_pcm_hw_open) card is not defined
aplay: main:533: audio open error: Invalid argument
(obviously I don't hear anything)

FWIW: this is a standard FC4 install which has been updated with all available
FC4 updates. I never touched anything from ALSA. To much voodoo for me :)
Comment 24 Martin Stransky 2005-12-04 16:53:37 EST
Could you please check this one?

$strace -o output.txt aplay -D modem:1 /usr/share/sounds/phone.wav

and attach the output.txt file.

Thanks.
Comment 25 Patrick 2005-12-06 06:03:09 EST
Created attachment 121899 [details]
Output of strace -o output.txt aplay -D modem:1 /usr/share/sounds/phone.wav as root
Comment 26 Patrick 2005-12-06 06:04:25 EST
Created attachment 121900 [details]
Output of strace -o output.txt aplay -D modem:1 /usr/share/sounds/phone.wav as a normal user
Comment 27 Martin Stransky 2005-12-06 09:48:39 EST
Do you really have the /etc/alsa/pcm/dmix.conf file?

See this line from output.txt:

open("/etc/alsa/pcm/dmix.conf", O_RDONLY) = -1 ENOENT (No such file or directory)

Comment 28 Patrick 2005-12-06 10:01:58 EST
For whatever reason it was not there. I copied it from the same rpm in
/var/cache/yum/updates-released/packages. The output of strace -o output.txt
aplay -D modem:1 /usr/share/sounds/phone.wav is attached.
Comment 29 Patrick 2005-12-06 10:03:02 EST
Created attachment 121909 [details]
Output of strace -o output.txt aplay -D modem:1 /usr/share/sounds/phone.wav as root with dmix.conf restored
Comment 30 Martin Stransky 2005-12-08 09:20:44 EST
Please check the latest update for FC4 (alsa-lib and alsa-update). Remove
dmix.conf/dsnoop.conf file (from /etc/alsa/pcm) and re-login (as a common user)
after the update. dmix.conf/dsnoop.conf files are generated by ainit utility
after login (but only if you logged in as a common user).
Comment 31 Martin Stransky 2005-12-09 04:58:49 EST
*** Bug 175220 has been marked as a duplicate of this bug. ***
Comment 32 Orion Poplawski 2005-12-12 18:00:11 EST
RE: 175220

Still getting errors with alsa-lib-1.0.10rf-3:

Starting SmartLink modem daemon:

ALSA lib conf.c:1592:(snd_config_load1) _toplevel_:51:23:No such file or directory
ALSA lib conf.c:2837:(snd_config_hook_load) /etc/alsa/cards/aliases.conf may be
old or corrupted: consider to remove or fix it
ALSA lib conf.c:2700:(snd_config_hooks_call) function snd_config_hook_load
returned error: No such file or directory
ALSA lib pcm.c:1969:(snd_pcm_open_conf) Invalid type for PCM modem:1 definition
(id: modem, value: cards.pcm.modem)
Comment 33 Patrick 2005-12-12 18:13:40 EST
(In reply to comment #30)
Since I needed a working OpenOffice.org Impress for a customer presentation I
had to temporarily revert to Rawhide on the laptop so can't test the new alsa
stuff. Have a few more the next few weeks so I'm afraid I'll have little
opportunity to put back FC4 and test it. If I get a chance I'll test it and
respond here.

Comment 34 Martin Stransky 2005-12-13 05:03:59 EST
If you have installed Rawhide I don't need to test FC4. So I guess this bug is
in Rawhide, too. Do you have the dmix.conf/dsnoop.conf files? They should be
generated after login as a common user...
Comment 35 Orion Poplawski 2005-12-13 15:50:33 EST
With a user logged into the console, the /etc/alsa/pcm/dmix.conf and dsnoop.conf
files are there.  With user logged off, they are gone.

Now this totally makes the slmodemd service unusable since it is started at
boot.  I imagine this breaks other things too.
Comment 36 Patrick 2005-12-20 17:41:16 EST
(In reply to comment #34)
yup both are there.  Also seen the behavior reported in comment #35. So it's not
possible at boot to start slmodem as a service but once the user is logged in
the slmodem service can be started succssfully. 
Comment 37 Martin Stransky 2005-12-29 10:08:12 EST
You can check this package for FC4/rawhide:

http://people.redhat.com/stransky/alsa-lib-1.0.10-1.FC4.test.src.rpm

but it's only hotfix. You have to remove the old alsa-lib package and install
this one, don't update.
Comment 38 Orion Poplawski 2006-01-03 17:35:25 EST
slmodemd appears to start fine at boot with the test package.
Comment 39 Martin Stransky 2006-01-13 10:55:56 EST
Should be fixed in RAWHIDE (FC5).

Note You need to log in before you can comment on or make changes to this bug.