Bug 175220 - /etc/alsa/cards/aliases.conf may be old or corrupted
/etc/alsa/cards/aliases.conf may be old or corrupted
Status: CLOSED DUPLICATE of bug 169729
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-07 15:57 EST by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-09 04:58:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2005-12-07 15:57:47 EST
Description of problem:

Trying to get slmodem-alsa working on a rawhide system, I was getting the
following errors:

ALSA lib conf.c:1592:(snd_config_load1) _toplevel_:51:23:No such file or directory
ALSA lib conf.c:2837:(snd_config_hook_load) /etc/alsa/cards/aliases.conf may be
old or corrupted: consider to remove or fix it
ALSA lib conf.c:2700:(snd_config_hooks_call) function snd_config_hook_load
returned error: No such file or directory
ALSA lib pcm.c:1969:(snd_pcm_open_conf) Invalid type for PCM modem:1,0
definition (id: modem, value: cards.pcm.modem)

moving /etc/alsa/cards/aliases.conf out of the way got things working for me.

# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: IXP [ATI IXP], device 0: ATI IXP AC97 [ATI IXP AC97]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Modem [ATI IXP Modem], device 0: ATI IXP MC97 [ATI IXP MC97]
  Subdevices: 0/1
  Subdevice #0: subdevice #0


Version-Release number of selected component (if applicable):
alsa-lib-1.0.10rf-2

How reproducible:
everytime
Comment 1 Martin Stransky 2005-12-09 04:58:46 EST

*** This bug has been marked as a duplicate of 169729 ***

Note You need to log in before you can comment on or make changes to this bug.