Bug 1697439 - python-requests-oauthlib-1.2.0 was updated but has missing deps
Summary: python-requests-oauthlib-1.2.0 was updated but has missing deps
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-requests-oauthlib
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fedora Infrastructure SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1729646 (view as bug list)
Depends On: 1730033
Blocks: PYTHON38 F31FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2019-04-08 13:08 UTC by Upstream Release Monitoring
Modified: 2019-08-14 23:02 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-14 23:02:32 UTC


Attachments (Terms of Use)

Description Upstream Release Monitoring 2019-04-08 13:08:26 UTC
Latest upstream release: 1.2.0
Current version/release in rawhide: 1.0.0-1.fc29
URL: https://github.com/requests/requests-oauthlib

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/11803/

Comment 1 Kevin Fenzi 2019-06-29 20:49:57 UTC
Built in rawhide.

Comment 2 Miro Hrončok 2019-07-10 11:52:54 UTC
The updated package fails to install:

Error: 
 Problem: conflicting requests
  - nothing provides python3.7dist(oauthlib) >= 3 needed by python3-requests-oauthlib-1.2.0-1.fc31.noarch

This blocks the Python 3.8 rebuild of dependent packages.

Comment 3 Kevin Fenzi 2019-07-10 20:41:58 UTC
Yes, I know, I realized it too late to untag. ;( 

There's several packages that depend on python-oauthlib, I need to see if they will work ok with the newer version before I update that. 
Sadly, none of them seem to have any versioned requires... 

cloud-init-0:17.1-10.fc31.noarch
python3-apprise-0:0.7.8-1.fc31.noarch
python3-jira-0:2.0.0-3.fc30.noarch
python3-requests-oauthlib-0:1.2.0-1.fc31.noarch
python3-social-auth-core-0:1.7.0-5.fc31.noarch

Comment 4 Kevin Fenzi 2019-07-13 20:26:52 UTC
ok. After looking at all those, I think it's ok to just update, but to be safe, I mailed devel list and all the maintainers about it...

Comment 5 John Dennis 2019-07-15 16:09:15 UTC
I just added a bug to update python-oauthlib to the current 3.0.2 version. I failed to catch the change in the dependency requirement when I updated python-requests-oauthlib. The bz to update python-oauthlib is bug #1730033

Comment 6 Miro Hrončok 2019-07-22 08:58:47 UTC
*** Bug 1729646 has been marked as a duplicate of this bug. ***

Comment 7 Miro Hrončok 2019-08-14 22:24:21 UTC
The coordinated rebuild of Python 3.8 has started in the `f32-python` side tag.

If you figure out how to rebuild this package, please don't rebuild it in regular rawhide, but use the side tag instead:

    on branch master:
    $ fedpkg build --target=f32-python

To wait for a build to show up in the side tag, do:

    $ koji wait-repo f32-python --build=<nvr>

Where <nvr> is name-version-release of the source package, e.g. python-foo-1.1-2.fc32.

An updated mock config is posted at:
http://copr.fedorainfracloud.org/coprs/g/python/python3.8/

Note that it will take a while before the essential packages are rebuilt, so don't expect all your dependencies to be available right away.

Thanks. Let us know if you need up to date info, or if you have any questions.



PS this message is mass posted to all the bugs that block the PYTHON38 bug. If this is also a Fedora 31 FTBFS bug and you manage to fix it, you can do a f31 build as usual:

    on branch f31:
    $ fedpkg build


Note You need to log in before you can comment on or make changes to this bug.